[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#636686: upgrade from squeeze to wheezy fails on i386 (pre-depends loop)

On Fri, Aug 26, 2011 at 04:40:49PM +0200, Aurelien Jarno wrote:
> >  - include the ld.so.conf.d multiarch snippets in the multiarch-support
> >    package, have libc Replaces: multiarch-support to take over these files
> >    on upgrade, and relax the multiarch-support dependency on i386 and armhf.
> >    (I haven't tested this solution; Adam proposed it on IRC, and it seems
> >    plausible.)

> I don't think this one is a good idea, it means that we rely on the
> ld.so.cache for executing system libraries. In case of problem with the
> cache, the system is simply broken, at least until ldconfig is ran
> manually or if the user tries to reboot the machine to fix the issue.

True.  That's a bit worse than unbuildability of embedded perl...

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: