[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#555205: libc6: segfault when upgrading from 2.9-25 -> 2.10.1-5 on squeeze renders system unusable

Package: libc6
Version: 2.9-25
Severity: critical
Justification: breaks the whole system

I tried to upgrade to the current "testing" version of libc6: 2.10.1-5

Below is the output from aptitude:

Preparing to replace libc-bin 2.9-25 (using .../libc-bin_2.10.1-5_i386.deb) ...
Unpacking replacement libc-bin ...
Processing triggers for man-db ...
Setting up libc-bin (2.10.1-5) ...
(Reading database ... 56540 files and directories currently installed.)
Preparing to replace libc6 2.9-25 (using .../libc6_2.10.1-5_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
Unpacking replacement libc6 ...
Setting up libc6 (2.10.1-5) ...
dpkg: error processing libc6 (--configure):
 subprocess installed post-installation script killed by signal (Segmentation fault)
Errors were encountered while processing:
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/bin/debsums ]; then /usr/bin/debsums --generate=nocheck -sp /var/cache/apt/archives; fi'
E: Sub-process returned an error code
E: Sub-process /usr/bin/dpkg returned an error code (1)

I was upgrading this system remotely (bad, yes, I know) and could no
longer enter any commands. Every command would return a "segmentation

Rebooting the system did not help either. I ultimately had to boot into
another OS and copy back the files from version 2.9-25 in order to have
a usable system.

I can try to provide additional details if necessary.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-2-486
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libc6 depends on:
ii  libc-bin                      2.9-25     GNU C Library: Binaries
ii  libgcc1                       1:4.4.1-4  GCC support library

Versions of packages libc6 recommends:
di  libc6-i686                    2.9-25     GNU C Library: Shared libraries [i

Versions of packages libc6 suggests:
ii  debconf [debconf-2.0]         1.5.28     Debian configuration management sy
pn  glibc-doc                     <none>     (no description available)
ii  locales                       2.9-25     GNU C Library: National Language (

-- debconf information:
* glibc/upgrade: true
* glibc/restart-services: spamassassin ssh saslauthd rsync openbsd-inetd mysql dovecot exim4 cron courier-authdaemon atd

Reply to: