[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debug version of ld-2.6.so is failing to start

I wanted to use dbg package of libc6 to trace down a libc function.
In order to use those libraries debug version of the libraries, i
tried following commands,

LD_LIBRARY_PATH=/usr/lib/debug gdb a.out
LD_LIBRARY_PATH=/usr/lib/debug:/usr/lib/debug/lib gdb a.out
LD_LIBRARY_PATH=/usr/lib/debug/lib/tls/i686/cmov gdb a.out
None of them worked for me.

Then i tried with the following command,
then i got SIGSEV.
Noticed the message from kernel log;
ld-2.9.so[4344]: segfault at 0 ip b8097852 sp bff24b00 error 6 in

Tried the dynamic loader manually like typing
"/usr/lib/debug/ld-2.9.so --list" but same seg-fault error again.
Also gdb give this message;
(gdb) run
Starting program: /usr/lib/debug/lib/ld-2.9.so
Cannot access memory at address 0x1d65c
This behavour is same on ubuntu sid and lenny too, and the memory
addresses that gdb points are same too.

Am i doing something wrong?

My system is latest lenny.
glibc6-dbg 2.9-25
kernel 2.6.30-1.686

Thanks in advance.

Reply to: