[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#534521: libc6-dev: /usr/include/fts.h cannot be compiled with -D_FILE_OFFSET_BITS=64

Package: libc6-dev
Version: 2.7-18
Severity: normal

/usr/include/fts.h, which is part of glibc, does not work with
transparent Large File Support.  This means that applications like pax
cannot be compiled with LFS (see bug 317466).

-- System Information:
Debian Release: 5.0.1
  APT prefers stable
  APT policy: (500, 'stable'), (50, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages libc6-dev depends on:
ii  libc6                    2.7-18          GNU C Library: Shared libraries
ii  linux-libc-dev           2.6.26-15lenny2 Linux support headers for userspac

Versions of packages libc6-dev recommends:
ii  gcc [c-compiler]              4:4.3.2-2  The GNU C compiler
ii  gcc-4.1 [c-compiler]          4.1.2-25   The GNU C compiler
ii  gcc-4.3 [c-compiler]          4.3.2-1.1  The GNU C compiler

Versions of packages libc6-dev suggests:
ii  glibc-doc                     2.7-18     GNU C Library: Documentation
ii  manpages-dev                  3.05-1     Manual pages about using GNU/Linux

-- no debconf information

Reply to: