[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#528929: debian-installer fails to install testing "squeeze" because libresolv-2.9.so segfaults

Package: libc6-udeb
Version: 2.9-4
Severity: grave

Hi there,

I've tried installing Debian testing "squeeze" using the weekly build ISO:
Date of the .iso:  11-May-2009 10:04

Debian Installer starts. When I am at the step "Configure the network", I'm able to choose the network adapter, configure the IP address, subnet mask, gateway, and nameserver. Then there's a the usual "Is this information correct ?" screen. I agree and then...

... I get a red screen with the error "This step failed..."

It appears this is because Debian Installer tried to start networking and failed.
On the Ctrl-Alt-F4 console I can see:
(note that I manually copied these lines from the screen, there might be small typos)
netcfg[9892]: INFO: executing: ip addr add broadcast dev eth0
kernel:[ 519.151840] netcfg[9892]: segfault at 7f7fd7b97436 ip 7f7fd6c0b719 sp 7fffdfda6380 error 7 in libresolv-2.9.so[7f7fd6c02000-13000]

Basically, libresolv just had a Segmentation fault.

If I repeat the same steps, I always get the same result. Obviously, I can't install Debian testing "squeeze" because of this, since I can never get the network configured.

Perhaps is libresolv broken in this build ?
Or maybe is debian-installer "not compatible" with this version of libresolv ?

This is libresolv-2.9.so which appears to come from libc6-udeb 2.9-4

This bug appears to be similar and/or related to bug 517231

Would be nice if someone could look into this.

Thank you,
Pierre Bauduin
Linux enthusiast since 1996
Linux registered user #64711
Debian GNU/Linux user
website: http://pierre.baudu.in/

Reply to: