[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#487104: nis: map values containing non-ascii characters vanish

broonie wrote:
> In any case, the major issue reported was with login and account lookups
> which are handled by the NSS module provided by glibc, the RCness being
> due to the inability to log in.

For clarity, my problem was that I was silently losing apache accounts
("make passwd" on my Solaris NIS server ssh's to my debian webserver
and runs a perl script that uses ypcat to update apache's htpasswd file)
which prevented users authenticating. This was brought to my attention
when someone was unable to access financial information that they should
have been able to view.

I tried creating some test shell accounts to see if the problem was
bigger than that but as I just wrote, I may have tested badly, as I
cannot now replicate that problem.

I still silently lose accounts when I run ypcat on the linux server.
(Apparently the locale setting is the culprit, so there is a workaround.)
I consider that this to be "serious data loss". At the very least it
is "data loss", so downgrade to "grave" would not bother me if people
are unhappy with it being marked "critical".

Note that on a Solaris 10 box, with UTF locale, ypcat does not lose

    $ LC_ALL=en_GB.UTF-8 ypcat passwd|grep Marks|awk -F: '{print $5}'|od -c
    0000000   K   .       M   a   r   k   s   t   r 367   m  \n


   Jonathan H N Chin     | deputy computer | Newton Institute, Cambridge, UK
<jc254@newton.cam.ac.uk> | systems manager | tel/fax: +44 1223 767091/330508

Reply to: