[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#464977: marked as done (libc6: iconv drops the last character in a windows-1255 string if it's non ascii)

Your message dated Sun, 2 Mar 2008 12:59:20 +0100
with message-id <20080302115920.GB7807@volta.aurel32.net>
and subject line Re: Bug#464977: Bug 464977: unreproducible
has caused the Debian Bug report #464977,
regarding libc6: iconv drops the last character in a windows-1255 string if it's non ascii
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

464977: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464977
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libc6
Version: 2.7-6
Severity: important

a valid windows-1255 string is translated to utf-8 by droping it's last char.

it happens only if that last char is non-ascii itself.

for example, "\xe1\xe2\xe3". it translates to a 2 characters long string.

it doesn't happen with other windows-* codepages, neither with the similar 
iso-8859-8 equivalent.

this is probably an upstream bug, but i report it here not to polute the 
upstream mailing list with not generally attending people. but i know 
debian maintainers are there :) .

best regards,


-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libc6 depends on:
ii  libgcc1                 1:4.3-20080116-1 GCC support library

libc6 recommends no packages.

-- debconf information:

--- End Message ---
--- Begin Message ---
On Sun, Mar 02, 2008 at 08:40:54AM +0200, alex bodnaru wrote:
> Aurelien Jarno wrote:
>> alex bodnaru a écrit :
>>> hi aurelien,
>>> i could run alex's test with no problem, so my memory is fine, too.
>>> the problem occured in a lua binding to iconv, and a few years ago in 
>>> php, but i don't remember whether iconv or recode binding
>> If the problem can't be reproduce with alex's test, it is more likely a 
>> bug in the lua binding. Care to report the bug here instead?
> i definitely agree with you. i will inquire it further in lua.

Ok, I am therefore closing the bug open on the glibc.

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

--- End Message ---

Reply to: