[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#438586: libc6 upgrade renders etch unusable



tag 438586 + unreproducible etch
found 438586 2.3.6.ds1-13etch4
notfound 438586 2.5-1
thanks

On Fri, Aug 17, 2007 at 11:18:18PM +0000, Nathan O. Siemers wrote:
> Package: libc6
> Version: latest pushed out as an update to etch.
> Severity: critical
>
> apt-get  update; apt-get install
>
> using vanilla etch and security sources on a chrooted ia32 debian system 
> is rendered unusable, with most binaries complaining of library errors:
>
> line:/# apt-get upgrade
> E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to 
> correct the problem.
> line:/# dpkg --configure -a
> dpkg: relocation error: /lib/libpthread.so.0: symbol errno, version 
> GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
>
> The system is now unusable, fortunately it is chrooted underneath a pure 
> amd64 debian etch system.  I'm afraid to run the update there.

  I don't really get what the problem is, I've no issue of the sort on
the etch system that I have at hand here.

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpwe3JaySTHc.pgp
Description: PGP signature


Reply to: