[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#430034: Apt-get upgraded packages, upgrade to libc6-2.5-9+b1 fails; recovery/downgrade complex

Package: libc6
Version: 2.3.6.ds1-13
Severity: normal

Apt-get upgrade installed many packages on a 2.4 kernel system, begins upgrade to libc6-2.5-9+b1 with warning to upgrade kernel. 

Libc6 upgrade fails with " subprocess pre-installation script returned error exit status 1". But apt-get -f install fails. 

This amateur attempt to downgrade:
"apt-get -s install --reinstall binutils-dev=2.15-6 binutils=2.15-6 cpp-3.3=1:3.3.5-13 g++=4:3.3.5-3 g++-3.3=1:3.3.5-13 g++-4.0- g++-4.1- gcc-3.3=1:3.3.5-13 gcc-3.3-base=1:3.3.5-13 gcc-4.0- gcc-4.1- gcc=4:3.3.5-3 gcj-3.3=1:3.3.5-13 libc6=2.3.6.ds1-13 libc6-dev=2.3.6.ds1-13 libgcj4-dev=1:3.3.5-13 libstdc++5=1:3.3.5-13 libstdc++5-3.3-dev=1:3.3.5-13 libstdc++6-4.0-dev- libstdc++6-4.1-dev-" fails with "Reinstallation of libc6 is not possible, it cannot be downloaded.
E: Version '2.3.6.ds1-13' for 'libc6-dev' was not found"

What restores a workable system when "apt-get upgrade" stops at 
"You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.5-5) but 2.3.6.ds1-13 is installed
    libc6-dev: Depends: libc6 (= 2.5-9+b1) but 2.3.6.ds1-13 is installed
      locales: Depends: glibc-2.5-1
      E: Unmet dependencies. Try using -f.?"

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'oldstable'), (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.4.27 (SMP w/1 CPU core)
Locale: LANG=en_CA, LC_CTYPE=en_CA (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages libc6 depends on:
ii  tzdata                        2007f-3    time zone and daylight-saving time

libc6 recommends no packages.

-- no debconf information

Reply to: