Bug#428655: libc6: preinst check makes upgrading old libc6 versions impossible
Justification: renders package unusable
If you currently have an old libc6 version (eg: 2.3.6.ds1-13) & kernel
(eg: 2.4.20-686) installed, then it is impossible to upgrade libc6 or the
When you attempt to upgrade libc6, the preinst script complains about
the kernel version being lower than 2.6.1:
Preparing to replace libc6 2.3.6.ds1-13 (using .../libc6_2.5-9+b1_i386.deb) ...
WARNING: POSIX threads library NPTL requires kernel version
2.6.1 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.
But when you attempt to upgrade the kernel, at least one of the kernel package
(linux-image-2.6-686) sub-dependencies depends on a more recent version
of libc6 than you currently have installed. This causes apt-get to
attempt to upgrade libc6 before the kernel, and you hit the same error as
Please find a way to enable people with old libc6 & kernel versions to
upgrade cleanly. Perhaps an explicit package dependency to 2.6 so apt-get can
sort out the dependancies.
Or if an automatic clean upgrade is not possible, then please add more info to
libc6's preinst error so admins know how to manually fix the problem.
Maybe admins in this unfortunate situation need need to disable the check
in the libc6 preinst then upgrade the kernel and libc6, then reboot
Or they need to first upgrade to the last version of libc6 which
didn't have this check (but which is hopefully new enough for
the kernel's sub-dependencies) before upgrading the kernel, then
upgrade libc6 afterwards & reboot immediately.
My current work-around is to switch over to stable until this problem is fixed.
-- System Information
Debian Release: testing/unstable
Kernel: Linux rr002701e001 2.4.20-686 #1 Mon Jan 13 22:22:30 EST 2003 i686
Locale: LANG=C, LC_CTYPE=C
Versions of packages libc6 depends on:
ii tzdata 2007e-3 Time Zone and Daylight Saving Time