[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#424057: marked as done (libc6: internal error: symidx out of range of fptr table)



Your message dated Sun, 20 May 2007 07:02:08 +0000
with message-id <E1HpfQe-0004Eg-7A@ries.debian.org>
and subject line Bug#424057: fixed in glibc 2.5-8
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libc6
Version: 2.5-7
Severity: important

Today I saw this error for the second time on my hppa box running the 
2.6.18-parisc64-smp kernel:
cat: error while loading shared libraries: internal error: symidx out of 
range of fptr table

People on #parisc say that this is a glibc issue:
<patofiero> fjp, I have not looked at the current sources in debian glibc, 
but in general there *are* functions which are supposed to be atomic but 
are not. These failures can cause a "symidx out of rang of fptr table" 
error.
<patofiero> fjp, The failure is in glibc.
<patofiero> fjp, It's using non-atomic implementation of compare and swap. 
However, the problem is systemic of a kernel that doesn't have atomic 
helper functions.
<fjp> I'm running 2.6.18-4-parisc64-smp
<patofiero> fjp, smp is more likely to trigger the error.
<patofiero> fjp, You have the atomic helper routines present in your 
kernel.
<patofiero> fjp, The glibc you have just isn't using them.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: hppa (parisc64)

Kernel: Linux 2.6.18-4-parisc64-smp (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Attachment: pgpJOPS8MfeVs.pgp
Description: PGP signature


--- End Message ---
--- Begin Message ---
Source: glibc
Source-Version: 2.5-8

We believe that the bug you reported is fixed in the latest version of
glibc, which is due to be installed in the Debian FTP archive:

glibc-doc_2.5-8_all.deb
  to pool/main/g/glibc/glibc-doc_2.5-8_all.deb
glibc_2.5-8.diff.gz
  to pool/main/g/glibc/glibc_2.5-8.diff.gz
glibc_2.5-8.dsc
  to pool/main/g/glibc/glibc_2.5-8.dsc
libc6-dbg_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-dbg_2.5-8_amd64.deb
libc6-dev-i386_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-dev-i386_2.5-8_amd64.deb
libc6-dev_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-dev_2.5-8_amd64.deb
libc6-i386_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-i386_2.5-8_amd64.deb
libc6-pic_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-pic_2.5-8_amd64.deb
libc6-prof_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6-prof_2.5-8_amd64.deb
libc6-udeb_2.5-8_amd64.udeb
  to pool/main/g/glibc/libc6-udeb_2.5-8_amd64.udeb
libc6_2.5-8_amd64.deb
  to pool/main/g/glibc/libc6_2.5-8_amd64.deb
libnss-dns-udeb_2.5-8_amd64.udeb
  to pool/main/g/glibc/libnss-dns-udeb_2.5-8_amd64.udeb
libnss-files-udeb_2.5-8_amd64.udeb
  to pool/main/g/glibc/libnss-files-udeb_2.5-8_amd64.udeb
locales-all_2.5-8_amd64.deb
  to pool/main/g/glibc/locales-all_2.5-8_amd64.deb
locales_2.5-8_all.deb
  to pool/main/g/glibc/locales_2.5-8_all.deb
nscd_2.5-8_amd64.deb
  to pool/main/g/glibc/nscd_2.5-8_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 424057@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aurel32@debian.org> (supplier of updated glibc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 20 May 2007 03:43:09 +0200
Source: glibc
Binary: libc0.1-prof libc6-dev-amd64 locales-all libc6-i686 libc6-dev-ppc64 libc0.3-pic glibc-doc libc0.3 libc6-dev-mipsn32 libc0.1-i686 libc0.1-i386 libc6-mips64 libc6.1-dev libc6-s390x libnss-files-udeb libc0.1-dev-i386 libc6-dev-sparc64 libc6-i386 libc0.3-dev libc6-udeb libc6-dbg libc6.1-pic libc6-dev libc0.3-prof libc6-sparcv9 libc0.1-udeb libc6-dev-i386 libc6.1-prof libc6-mipsn32 libc0.1-dev locales libc6-pic libc0.3-udeb libc6-dev-powerpc libc0.1-pic libc6-ppc64 libc0.3-dbg libc0.1-dbg libc6-amd64 libc0.1 libc6-prof libc6-xen libc6-dev-mips64 libc6-powerpc libc6 libc6-sparcv9b libc6.1-udeb libc6.1-dbg nscd libc6-sparc64 libnss-dns-udeb libc6.1 libc6-dev-s390x
Architecture: source amd64 all
Version: 2.5-8
Distribution: unstable
Urgency: low
Maintainer: Aurelien Jarno <aurel32@debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
Description: 
 glibc-doc  - GNU C Library: Documentation
 libc6      - GNU C Library: Shared libraries
 libc6-dbg  - GNU C Library: Libraries with debugging symbols
 libc6-dev  - GNU C Library: Development Libraries and Header Files
 libc6-dev-i386 - GNU C Library: 32bit development libraries for AMD64
 libc6-i386 - GNU C Library: 32bit shared libraries for AMD64
 libc6-pic  - GNU C Library: PIC archive library
 libc6-prof - GNU C Library: Profiling Libraries
 libc6-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libnss-dns-udeb - GNU C Library: NSS helper for DNS - udeb (udeb)
 libnss-files-udeb - GNU C Library: NSS helper for files - udeb (udeb)
 locales    - GNU C Library: National Language (locale) data [support]
 locales-all - GNU C Library: Precompiled locale data
 nscd       - GNU C Library: Name Service Cache Daemon
Closes: 422625 423870 424057
Changes: 
 glibc (2.5-8) unstable; urgency=low
 .
   [ Aurelien Jarno ]
   * debian/sysdeps/depflags.pl: Add a conflicts on binutils
     (<< 2.17cvs20070426-1) for libc-dev.  Closes: #422625.
 .
   [ Clint Adams ]
   * debian/sysdeps/depflags.pl: Clean out relationships for packages
     that do not exist in sarge or later.
   * debian/debhelper.in/libc.install: do not hardcode the glibc
     version number in the path to gai.conf.
   * debian/control.in/main, debian/sysdeps/depflags.pl:
     use linux-libc-dev to build on all linux architectures.
     (retain Depends alternative on linux-kernel-headers)
 .
   [ Aurelien Jarno ]
   * debian/local/etc_init.d/glibc.sh: fix a typo.  Closes: #423870.
   * debian/patches/hppa/submitted-atomic_h.diff: new patch to fix the
     atomic CAS function on hppa.  Closes: #424057.
   * debian/control.in/main: unify the gcc-4.1 depends to (>= 4.1.2-6).
Files: 
 e00b2570bd96ede50af0e90929f6e77f 2293 libs required glibc_2.5-8.dsc
 0d2d84f67947d6e3ad82726f63fb1bcd 1131736 libs required glibc_2.5-8.diff.gz
 6eee842d2c0ab03e0a47c4a238f91cc9 1606756 doc optional glibc-doc_2.5-8_all.deb
 2a4fe9de92cb1fc713dbdee4734b0a33 4083830 libs standard locales_2.5-8_all.deb
 888c0e7c3988da70ac1a57056b0d9c8d 4889856 libs required libc6_2.5-8_amd64.deb
 086e53141741a640970fd1600c27af01 2472074 libdevel optional libc6-dev_2.5-8_amd64.deb
 689012bdb255c587acd8eb07a16d9fd8 1909774 libdevel extra libc6-prof_2.5-8_amd64.deb
 e540f1a976f69cfc4afa284826ae96ae 1453404 libdevel optional libc6-pic_2.5-8_amd64.deb
 c4c79953aa28930c758bd7bd175cea87 1927856 libs extra locales-all_2.5-8_amd64.deb
 7ae77d7b3ca1b44a97a4ab6cf3a4cabf 3691562 libs optional libc6-i386_2.5-8_amd64.deb
 b746a0724f816312d05f6bf30166edc0 1859088 libdevel optional libc6-dev-i386_2.5-8_amd64.deb
 3c741d4af874c878d1808f8af86916df 156892 admin optional nscd_2.5-8_amd64.deb
 8b2308ea0ea9ccee14e956f318909c92 5080968 libdevel extra libc6-dbg_2.5-8_amd64.deb
 506b05fd1271ed487d55874fa2966585 1101898 debian-installer extra libc6-udeb_2.5-8_amd64.udeb
 9011379ed1da6749ee1ba3406fc0f0ff 9504 debian-installer extra libnss-dns-udeb_2.5-8_amd64.udeb
 32ef9c79a9e395fab4ae8547b7bd7686 17772 debian-installer extra libnss-files-udeb_2.5-8_amd64.udeb
Package-Type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGT+zbw3ao2vG823MRAqR/AJ97iyrtUZirP2ub299/Th+/DZbFxgCfaX83
ydi1Z0zBTBZvwqwkdyWRoMY=
=xbAi
-----END PGP SIGNATURE-----


--- End Message ---

Reply to: