[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#420301: libc6: IPv6 transport fails for resolver

> I am not able to reproduce the problem. I am using an IPv6 nameserver in
> /etc/resolv.conf on a dozen of machines running glibc 2.5 without problem.
> Are you sure the bug has been triggerd by an upgrade to glibc 2.5? Then
> could you send me the content of /etc/nsswitch.conf and /etc/resolv.conf?

No, I'm not sure this bug was triggered by a 2.5 upgrade.  This is the
first time I tried using IPv6 for DNS transport.

When I've tried using it, my resolv.conf looks like:

#options inet6
search sentinelchicken.org
nameserver 2002:CFAC:5504:2::0

(Of course, I've tried with the options line uncommented as well.)

I have not modified my nsswitch.conf from its default, and it contains:

# /etc/nsswitch.conf
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat
group:          compat
shadow:         compat

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

Is there anything I can do to debug this directly on my system?  I don't
see anything in my system logs, which I didn't really expect to.


Reply to: