[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419189: not due to ubuntu or knoppix

Aurelien Jarno a écrit :
> Craig Small a écrit :
>> I do not believe the problem just stems from having foreign libraries in
>> it, as my system is stock Debian and I have a similar problem.    No
>> Ubuntu, no knoppix, just straight Debian.
>> apt-get install (some packages) which pulled in a new libc, I think.
>> Now I get this:
>> csmall@gonzo:~$ mutt
>> mutt: /lib/tls/libc.so.6: version `GLIBC_2.3.4' not found (required by mutt)
>> or this
>> gonzo:/home/csmall# sync
>> sync: relocation error: /lib/tls/libc.so.6: symbol _dl_starting_up,
>> version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time
>> reference
> Did you tried to upgrade from sarge or from etch?

>From the tests I have made here, I guess it was an upgrade from etch,
but you still have a sarge glibc unpacked manually into /lib and /lib/tls.

This is a problem of your system, and not of the package, however we
have improved our tests to detect such broken systems. The glibc should
now refuse to be installed until the problem is fixed.

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: