[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419830: unmet dependency: locales: Depends: glibc-2.5-1 which is a virtual package.

Package: locales
Version: 2.5-2

Not sure what is going on here.  Not able to install locales package.
Here is output:

$ sudo aptitude install locales
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages are BROKEN:
  fglrx-kernel-2.6.18-4-686 locales
The following packages will be automatically REMOVED:
  belocs-locales-bin belocs-locales-data
The following packages have been kept back:
  debhelper docbook-xml initramfs-tools libnotify1 lmodern python-gtk2
The following packages will be REMOVED:
  belocs-locales-bin belocs-locales-data
0 packages upgraded, 1 newly installed, 2 to remove and 7 not upgraded.
Need to get 4029kB of archives. After unpacking 618kB will be freed.
The following packages have unmet dependencies:
  locales: Depends: glibc-2.5-1 which is a virtual package.
  fglrx-kernel-2.6.18-4-686: Depends: fglrx-driver (= 8.28.8-4) but 8.35.5-1 is                       installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
locales-all [2.5-1 (unstable)]

Keep the following packages at their current version:
locales [Not Installed]

Downgrade the following packages:
fglrx-driver [8.35.5-1 (now) -> 8.28.8-4 (unstable)]

Score is -10164

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.

Based on what it is suggesting, I should install locales-all, but it doesn't seem right to have to install all the locales when I only need one or two.

I re-ran aptitude and it offered another solution, to install belocs-locales-bin and belocs-locales-data.  I did this but am still getting the nasty perl warnings all the time.

Reply to: