[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419189: Error on installing libc6 2.5-1 - breaks system



johfel@gmx.de a écrit :
> Package: libc6
> Version: 2.5-1
> Severity: critical
> 
> If I upgrade to libc6 2.5-1, I'll get this error:
> 
> Preparing to replace libc6 2.5-1 (using .../archives/libc6_2.5-1_i386.deb) ...
> Unpacking replacement libc6 ...
> Setting up libc6 (2.5-1) ...
> dpkg: relocation error: /lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
> iconvconfig: relocation error: /lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
> /usr/bin/perl: relocation error: /lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference

You are trying to replace libc6 version 2.5-1 with the same version.
This is something authorized that should work. In your case this fails
because of the presence of /lib/tls/libc.so.6. However this file does
not belong to libc6 2.5-1, it should have been during the upgrade from
2.3.6 to 2.5.

So my question is why did you do before trying to replace libc6 version
2.5-1 with the same version?

-- 
  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net



Reply to: