[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419036: Kernel panic - attempted to kill init!

Ali Servet Donmez a écrit :
> Package: libc6-i686
> Version: 2.5-1
> First of all i'm terribly sorry that i can't give you too much info.
> because i can't boot my system anymore due this problem.
> I tried to upgrade my unstable system today, i had errors and my
> system frozen, so i tried to reboot it, now i'm having these error
> messages at system boot:
> (quote "/sbin/init: Relocation error: /lib/tls/i686/cmov/libc.so.6:
> Symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file
> ld-linux.so.2 with link time reference
> Kernel panic - not syncing. Attempted to kill init!")
> Consider that, quote above might have typos, since i couldn't
> copy&paste it, but wrote down on a paper.
> Unfortunately, no further info. is available; but please let me now
> how can i extract more info. from this un-bootable (at least i can't)
> system to help you, in case you need.

To repair your system, you will have to boot it from a CD or an other
distro, and do a "mv /lib/tls /lib/tls.old".

When your system is repaired, it would be nice if you can give us the
output of:
- dpkg -l "libc6*"
- cat /etc/ld.so.hwcappkgs
- cat /etc/ld.so.nohwcap

This will help us to find the problem.


  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: