[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#369940: marked as done (libc6 upgrade objects to my old a.out libc in /usr/local)



Your message dated Sun, 11 Feb 2007 23:34:50 +0100
with message-id <20070211223450.GQ11573@hades.madism.org>
and subject line Close with versions
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libc6
Version: 2.3.2.ds1-22sarge3

 Preparing to replace libc6 2.3.2.ds1-22 (using .../libc6_2.3.2.ds1-22sarge3_i386.deb) ...
 These libraries were found in /usr/local/lib:
 libc.so.2
 libc.so.2.2
 libm.so.2
 libm.so.2.2

 A copy of glibc was found in an unexpected directory.
 It is not safe to upgrade the C library in this situation;
 please remove that copy of the C library and try again.
 dpkg: error processing
 debian/pool/main/g/glibc/libc6_2.3.2.ds1-22sarge3_i386.deb (--install):
  subprocess pre-installation script returned error exit status 1

...

-chiark:~> file /usr/local/lib/libc.so.2.2
/usr/local/lib/libc.so.2.2: Linux/i386 demand-paged executable (ZMAGIC), stripped
-chiark:~>

What exactly is the problem here ?

Ian.


--- End Message ---
--- Begin Message ---
Version: 2.3.6.ds1-10

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpGB5BN_hXH6.pgp
Description: PGP signature


--- End Message ---

Reply to: