[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#406128: libc6-i686: xmms mplayer alsaplayer and maybe others segfault

Package: libc6-i686
Severity: critical
Justification: breaks unrelated software

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=it_IT@euro, LC_CTYPE=it_IT@euro (charmap=ISO-8859-15)

it is quite a while that mplayer kept segfaulting, i didn't bother too
much because i'm used to problems with that program which are generally
settled in a short period, but some days ago i noticed that xmms and
alsaplayer segfaulted as well.
it is not a real problem because this is my home server and i use the
other pc's to listen to music and play videos, but i wished to find out
the reason of it.
if i ran ldd of the executables i got (e.g. alsaplayer):
aldo@topolino:~$ ldd /usr/bin/alsaplayer
linux-gate.so.1 =>  (0xffffe000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7f67000)
libdl.so.2 => /lib/tls/libdl.so.2 (0xb7f63000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7e7e000)
libm.so.6 => /lib/tls/libm.so.6 (0xb7e59000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7e4e000)
libc.so.6 => /lib/tls/libc.so.6 (0xb7d1b000)
/lib/ld-linux.so.2 (0xb7f8b000)

the only strange line (at least for me) was the last one and it was the
same running ldd of the three programs
that lib is a symlink to ld-2.3.6.so
dpkg -S ld-2.3.6.so  showed that this library is included both in libc6 and
libc6-i686 (which i installed because it is reccomended by recent 2.6.x

i ran ldconfig which gave the following output:
topolino:/etc# ldconfig -v |grep -i ld-linux.so.2
ldconfig: Cannot stat /usr/lib/libgthumb-2.6.9.so: No such file or
ldconfig: Cannot stat /usr/lib64/libg2c.so: No such file or directory
        ld-linux.so.2 -> ld-2.3.6.so
        ld-linux.so.2 -> ld-2.3.6.so

but it did not solve the problem

eventually i have decided to uninstall either libc6 or libc6-i686,
obviously i chose the second which apparently is just recommended by the
latest kernels

now xmms, alsaplayer and mplayer work flawlessly


Reply to: