[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#364698: [Debian-ia32-libs] Bug#364698: ia32-libs: GLIBC_2.0 is not defined (used to be)

Steve Langasek <vorlon@debian.org> writes:

> Now, the ia32-libs maintainers *could* include a non-NPTL build of glibc in
> ia32-libs, and then you could use LD_ASSUME_KERNEL=2.4.1 to force the use of
> this backwards-compatible glibc with the errno@GLIBC_2.0 symbol; but given
> that even the i386 port of etch isn't going to support these applications by
> default, I'm not sure I see the point...

No, we can't. We don't provide any libc at all anymore. :)

Glibc builds a 32bit libc6 for amd64 and ia32-libs has depended on it
for the last few versions.

If you need this ancient, broken errno variable then you have to stick
with stable I guess. But it is out of our hands and in the hands of
the glibc team. reassigning the bug there.


Reply to: