[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#354749: kernel panic with libc6-2.3.6-2

Frits Daalmans a écrit :
Subject: kernel panic with libc6-2.3.6-2
Package: libc6
Version: 2.3.5-13
Severity: critical
Justification: breaks the whole system



Each week I try out the progress of Etch, and yesterday
I upgraded libc6 (and libc6-amd64) from 2.3.5-13 to 2.3.6-2

I suppose you mean sid here, Etch still has libc6 2.3.5-13.

* and continued working successfully with no problems*
Today I boot my PC resulting in a kernel panic at boot (repeatedly,
at the same location, reproducibly). Something about not being able
to locate the root device. Since this is on a S-ATA disk on a
MSI motherboard with nforce3 chipset that I had serious trouble with
in the past (changing the names of its disks from hde5 <-> sda5 and back)
I tried both booting with option root=/dev/sda5 and with root=/dev/hde5
to no avail.

Would it be possible to send a copy of the boot log, without that, it will be really difficult to debug the problem.

It took me quite a while to figure out what it was that broke
the system.
Kernel 2.6.15 failed to boot; in an older kernel 2.6.8 on the
same hardware the system booted fine.

downgrading libc6 from 2.3.6-2 to 2.3.5-13 solved the problem.

Have you regenerated the initrd image after downgrading this package? It is the only place where libc6 is used _before_ the root filesystem is mounted.

Have you made any other changes when downgrading?

I'm really sorry that I can't pinpoint the problem better... good luck!!

PS: I've also installed udev 0.084-5, hal 0.5.6-4 and dbus 0.60.5 in case that's of any help..

Are you sure udev is not the cause of your problems? Looks more probable.


  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: