[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#332795: locales: post-install fails with *** glibc detected *** double free or corruption (!prev): 0x088e9208 ***

On Sat, Oct 08, 2005 at 07:21:32PM +0200, Attila Kinali wrote:
> Package: locales
> Version: 2.3.5-6
> Severity: grave
> Justification: renders package unusable
> when updating locales to version 2.3.5-6 it failes after
> generating the locales:
> ---
> jashugan:/home/attila# apt-get install locales
> Reading Package Lists... Done
> Building Dependency Tree... Done
> locales is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 317 not upgraded.
> 1 not fully installed or removed.
> Need to get 0B of archives.
> After unpacking 0B of additional disk space will be used.
> Setting up locales (2.3.5-6) ...
> Generating locales (this might take a while)...
>   de_DE.ISO-8859-1... done
> Generation complete.
> *** glibc detected *** double free or corruption (!prev): 0x088e9208 ***
> dpkg: error processing locales (--configure):
>  subprocess post-installation script killed by signal (Aborted), core dumped
> Errors were encountered while processing:
>  locales
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> ---
> I tried other locales and it does seem to be unrelated.
> As i have no idea what the error means i could not really debug
> it, if you need more informations please tell me how to aquire them.

Can you still reproduce this?  If so, it says that bash dumped core;
the core dump should be lying around somewhere.  That might help.

I've tried to reproduce this but could not.

Daniel Jacobowitz
CodeSourcery, LLC

Reply to: