[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#321796: marked as done (libc6 errors with libphp4.so after recent libc6 update)



Your message dated Fri, 19 Aug 2005 06:17:17 -0700
with message-id <E1E66kH-00047B-00@spohr.debian.org>
and subject line Bug#323560: fixed in glibc 2.3.5-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 7 Aug 2005 16:13:14 +0000
>From mperry@lnxpowered.org Sun Aug 07 09:13:14 2005
Return-path: <mperry@lnxpowered.org>
Received: from m206-45.dsl.tsoft.com (orion.lnxpowered.org) [198.144.206.45] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1E1nly-0001Ys-00; Sun, 07 Aug 2005 09:13:14 -0700
Received: from [192.168.1.16] (unknown [192.168.1.16])
	by orion.lnxpowered.org (Postfix) with ESMTP id 9CADD2C8043
	for <submit@bugs.debian.org>; Sun,  7 Aug 2005 09:12:09 -0700 (PDT)
Message-ID: <42F63304.6030707@lnxpowered.org>
Date: Sun, 07 Aug 2005 09:12:52 -0700
From: Michael Perry <mperry@lnxpowered.org>
User-Agent: Thunderbird 1.0+ (Windows/20050803)
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: libc6 errors with libphp4.so after recent libc6 update
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libc6
Version: 2.3.5-3
Severity: important

I was reading bug 321712 and am seeing the same output in my 
/var/log/apache/error.log for failing to load libphp4 into the running 
server with the message below:

Cannot load /usr/lib/apache/1.3/libphp4.so into server: 
/lib/tls/libresolv.so.2: symbol __res_maybe_init, version GLIBC_PRIVATE 
not defined in file libc.so.6 with link time reference

I updated to the latest version of libc6 last night that is in unstable. 
  Sometime around 0620 this morning apache just terminated and was not 
running on my web server and required a manual restart.

-- 
Michael Perry | Do or do not. There is no try --Master Yoda
mperry@lnxpowered.org | http://www.lnxpowered.org

---------------------------------------
Received: (at 323560-close) by bugs.debian.org; 19 Aug 2005 13:27:11 +0000
>From katie@spohr.debian.org Fri Aug 19 06:27:11 2005
Return-path: <katie@spohr.debian.org>
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1E66kH-00047B-00; Fri, 19 Aug 2005 06:17:17 -0700
From: GOTO Masanori <gotom@debian.org>
To: 323560-close@bugs.debian.org
X-Katie: $Revision: 1.56 $
Subject: Bug#323560: fixed in glibc 2.3.5-4
Message-Id: <E1E66kH-00047B-00@spohr.debian.org>
Sender: Archive Administrator <katie@spohr.debian.org>
Date: Fri, 19 Aug 2005 06:17:17 -0700
Delivered-To: 323560-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 14

Source: glibc
Source-Version: 2.3.5-4

We believe that the bug you reported is fixed in the latest version of
glibc, which is due to be installed in the Debian FTP archive:

glibc-doc_2.3.5-4_all.deb
  to pool/main/g/glibc/glibc-doc_2.3.5-4_all.deb
glibc_2.3.5-4.diff.gz
  to pool/main/g/glibc/glibc_2.3.5-4.diff.gz
glibc_2.3.5-4.dsc
  to pool/main/g/glibc/glibc_2.3.5-4.dsc
libc6-dbg_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6-dbg_2.3.5-4_i386.deb
libc6-dev_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6-dev_2.3.5-4_i386.deb
libc6-i686_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6-i686_2.3.5-4_i386.deb
libc6-pic_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6-pic_2.3.5-4_i386.deb
libc6-prof_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6-prof_2.3.5-4_i386.deb
libc6-udeb_2.3.5-4_i386.udeb
  to pool/main/g/glibc/libc6-udeb_2.3.5-4_i386.udeb
libc6_2.3.5-4_i386.deb
  to pool/main/g/glibc/libc6_2.3.5-4_i386.deb
libnss-dns-udeb_2.3.5-4_i386.udeb
  to pool/main/g/glibc/libnss-dns-udeb_2.3.5-4_i386.udeb
libnss-files-udeb_2.3.5-4_i386.udeb
  to pool/main/g/glibc/libnss-files-udeb_2.3.5-4_i386.udeb
locales_2.3.5-4_all.deb
  to pool/main/g/glibc/locales_2.3.5-4_all.deb
nscd_2.3.5-4_i386.deb
  to pool/main/g/glibc/nscd_2.3.5-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 323560@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
GOTO Masanori <gotom@debian.org> (supplier of updated glibc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat,  6 Aug 2005 06:52:42 +0900
Source: glibc
Binary: libc6-i686 libc6-dev-ppc64 libc0.3-pic glibc-doc libc1-udeb libc0.3 libc6.1-dev libc1-pic libc6-s390x libnss-files-udeb libc1-dbg libc6-dev-sparc64 libc0.3-dev libc6-udeb libc6-dbg libc6.1-pic libc6-dev libc0.3-prof libc6-sparcv9 libc6.1-prof libc1 locales libc6-pic libc0.3-udeb libc1-prof libc6-ppc64 libc0.3-dbg libc6-prof libc6 libc6-sparcv9b libc6.1-udeb libc6.1-dbg nscd libc6-sparc64 libnss-dns-udeb libc6.1 libc1-dev libc6-dev-s390x
Architecture: source i386 all
Version: 2.3.5-4
Distribution: unstable
Urgency: low
Maintainer: GOTO Masanori <gotom@debian.org>
Changed-By: GOTO Masanori <gotom@debian.org>
Description: 
 glibc-doc  - GNU C Library: Documentation
 libc6      - GNU C Library: Shared libraries and Timezone data
 libc6-dbg  - GNU C Library: Libraries with debugging symbols
 libc6-dev  - GNU C Library: Development Libraries and Header Files
 libc6-i686 - GNU C Library: Shared libraries [i686 optimized]
 libc6-pic  - GNU C Library: PIC archive library
 libc6-prof - GNU C Library: Profiling Libraries
 libc6-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libnss-dns-udeb - GNU C Library: NSS helper for DNS - udeb (udeb)
 libnss-files-udeb - GNU C Library: NSS helper for files - udeb (udeb)
 locales    - GNU C Library: National Language (locale) data [support]
 nscd       - GNU C Library: Name Service Cache Daemon
Closes: 321561 321712 321717 321718 321719 321740 321796 322506 322768 323352 323409 323487 323552 323560
Changes: 
 glibc (2.3.5-4) unstable; urgency=low
 .
   * The "hppa is important to someone, really - LaMont" release.
 .
   * GOTO Masanori <gotom@debian.org>
 .
     * d-i wants to remove libnss-files-udeb and libnss-dns-udeb dependency
       from libc-udeb.  Suggested by Joey Hess <joeyh@debian.org>.
       (Closes: #322506)
       - debian/control.in/libc: Remove libnss-files-udeb libnss-dns-udeb
         dependency.
       - debian/control: Update.
 .
     * Build-Depends fixes:
       - debian/control.in/main: Change gcc-* dependency from | to ,.
         Suggested by Andreas Jochens <aj@andaco.de>.
       - debian/control.in/main: Add gcc-4.0 (>= 4.0.1-5) [hppa], because prior
         versions cannot generate sane glibc binaries.
       - debian/control: Update.
 .
     * Enable libnss upgrade guard again.
       (Closes: #321561, #321712, #321796, #322768, #323560)
       - debian/debhelper.in/libc.preinst: Change guard to 2.3.5-1.
       - debian/debhelper.in/libc.postinst: Likewise.
       - debian/debhelper.in/libc.postinst: Fix to invoke NSS check again.
 .
     * debian/debhelper.in/nscd.dirs: Add /var/db/nscd.
       (Closes: #323352, #323487)
 .
     * debian/debhelper.in/locales.prerm: Add purge to remove locale-archive.
       (Closes: #321719)
 .
     * debian/patches/00list: Drop glibc234-hppa-remove-mallocdef.dpatch.
       It causes unconditional locking problem, because it was already replaced
       by Carlos' new patches.  Reported by LaMont Jones <lamont@debian.org>.
 .
     * Add Depends: lib64gcc1 and provide lib64c-dev for 64bit -dev packages.
       Suggested by Matthias Klose <doko@cs.tu-berlin.de>.  (Closes: #323552)
       - debian/control.in/sparc64: Likewise.
       - debian/control.in/ppc64: Likewise.
       - debian/control.in/s390x: Likewise.
       - debian/control: Update.
 .
     * debian/patches/glibc235-dl-execstack.dpatch: New file, to fix execstack
       failed to check on kernel <= 2.4.18.  (Closes: #321717, #321718, #323409)
 .
     * Roland Stigge <stigge@antcom.de>:
       - debian/debhelper.in/glibc-doc.install: Install HTML documents
         correctly.  (Closes: #321740)
Files: 
 b5f966da1bac2037f2c3250939665bf2 1733 libs required glibc_2.3.5-4.dsc
 cce2797679eb5a72552917205c58a8e2 294918 libs required glibc_2.3.5-4.diff.gz
 68c56229f8570af8f2f257cd3c2f3f2c 3330198 doc optional glibc-doc_2.3.5-4_all.deb
 37cb28ab4c4cfdd20ba8368f4fc98721 4057888 base standard locales_2.3.5-4_all.deb
 bb6dbd9475c74a4946092d32dcf9d148 4927430 base required libc6_2.3.5-4_i386.deb
 11c55fbdd91e3bb9bce31fa26f25dbea 2678864 libdevel standard libc6-dev_2.3.5-4_i386.deb
 79bbe3c04e2aa80abd32c23fa99aa053 1262672 libdevel extra libc6-prof_2.3.5-4_i386.deb
 7be8aef8e28c3ff7e6e8abcdbf6956ed 1010100 libdevel optional libc6-pic_2.3.5-4_i386.deb
 0448a23476d35e8d6b36d89648286b60 1006866 libs extra libc6-i686_2.3.5-4_i386.deb
 ff78ac9f175de45621c1fb49b734ca36 122578 admin optional nscd_2.3.5-4_i386.deb
 e7e7823b042a459c238a7bd4cbed6471 5945942 libdevel extra libc6-dbg_2.3.5-4_i386.deb
 2c946e6bf4c8f0d6d5f94da17597e30c 702862 debian-installer extra libc6-udeb_2.3.5-4_i386.udeb
 ccc70c566c634c19b44f53e309df03cd 8270 debian-installer extra libnss-dns-udeb_2.3.5-4_i386.udeb
 016ab73700c3956503915f65c7f06544 14856 debian-installer extra libnss-files-udeb_2.3.5-4_i386.udeb
package-type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDBdSoqIqasIZIJsMRAu/BAJ9JlI/xi3WXxvCOt9Ev7AqGTK9gbwCfSbz7
f6wWT3sxSMKyy/LsRc6s7cU=
=7XOJ
-----END PGP SIGNATURE-----



Reply to: