[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#306546: nscd/libc6: Assertion failed on login/su, any user

On Thu, 28 Apr 2005, GOTO Masanori wrote:

Before we suspect glibc, it's better to clear what actually causes
your problem.  2.3.2.ds1-20 and -21 do not have any nscd/NSS
modifications.  The almost all code have been used over 1.5 years.  So
I think it's your local environment/machine trouble rathar than glibc
As mentioned before, all machines I've seen this problem on are K8-generation AMDs (with appropriately configured kernels), so it's quite likely this is one part of the environment which made the bug emerge. However, nscd is definitely connected with the problem. To illustrate, here is a simple test I have just performed:

1. With nscd running:
 - root can neither log in locally nor be su'd to
 - a local (passwd/shadow) user - ditto
 - an user from LDAP (libnss-ldap/pam_ldap) - ditto

2. With nscd stopped:
 - root cannot log in locally but can be su'd to
 - local user - ditto
 - LDAP user - CAN log in locally and can be su'd to

Also, I remember that when upgrading from -20 to -21 I got informed that stopping nscd failed - both in i386 and amd64 case. Of course that could just be a buggy init script and not a problem with nscd itself.

You wrote you upgraded to the -20, but it's not the latest version.
Well, that's the last version I get when I run dist-upgrade on all the Debian-i386 machines I manage, configured to use the "sarge" branch; I had to download the debs manually to try upgrading to -21. For a moment I thought the mirror I use (Switch) is out of date, but it's the same on ftp.debian.org. Debian-amd64 has already upgraded to ds1-21, but AFAIK "their" sarge is still ranked unstable, so the difference is not surprising.

Which version did you use without problem?
I wish I could remember... Does apt log upgrades somewhere? Unfortunately I didn't have apt-listchanges installed at that time.

Which version do you have problem with?
ds1-20 on AMD64, ds1-20 and ds1-21 on i386. I haven't tried anything else.

What packages did you upgrade with glibc at that time?
Here's the weird part: Monday's upgrade which caused login and su to start misbehaving was nscd ONLY. Nothing else.

Please let me know if you need any further information.


Reply to: