[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#231748: libc6-dev: programs using HUGE_VAL will issue a warning when compiled with -pedantic on the g++-3.3

Followup-For: Bug #231748
Package: libc6-dev
Version: 2.3.2.ds1-20

I ran into the same problem when trying to compile mapserver with
-pedantic using gcc 3.3.5.  Not sure how to solve the problem, but
this bug make it hard to convince the mapserver developers to use
-pendantic.  I want to convince them to add more warnings flags in a
try to get the code ready for all the archs in Debian, and it gets
harder when bogus warnings are emited from the compiler. :/

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.26-1-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages libc6-dev depends on:
ii  libc6                2.3.2.ds1-20        GNU C Library: Shared libraries an
ii  linux-kernel-headers 2.5.999-test7-bk-17 Linux Kernel Headers for developme

-- no debconf information

Reply to: