[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265493: marked as done (locales: getting always a warning message)



Your message dated Fri, 13 Aug 2004 21:31:50 +0900
with message-id <81smar43t5.wl@omega.webmasters.gr.jp>
and subject line Bug#265493: locales: getting always a warning message
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 13 Aug 2004 12:00:49 +0000
>From nico@woje.it Fri Aug 13 05:00:49 2004
Return-path: <nico@woje.it>
Received: from mail-relay-4.tiscali.it [213.205.33.44] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Bvajp-0008VJ-00; Fri, 13 Aug 2004 05:00:49 -0700
Received: from [127.0.0.1] (62.11.54.183) by mail-relay-4.tiscali.it (7.1.021.3)
        id 40F3EBEA007AC5A3; Fri, 13 Aug 2004 14:00:18 +0200
Message-ID: <40F3EBEA007AC5A3@mail-relay-4.tiscali.it> (added by postmaster@mail-relay-4.tiscali.it)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: =?iso-8859-15?q?Nicol=C3=B2_Wojewoda?= <nico@woje.it>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: locales: getting always a warning message
Bcc: =?iso-8859-15?q?Nicol=C3=B2_Wojewoda?= <nico@woje.it>
X-Mailer: reportbug 2.64
Date: Fri, 13 Aug 2004 13:53:57 +0200
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 

Package: locales
Version: 2.3.2.ds1-16
Severity: normal

I always get (when installing, removing or reconfiguring packages) the warning message you can read under the "-- debconf information" label.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.7-1-k7
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8

Versions of packages locales depends on:
ii  debconf                     1.4.30       Debian configuration management sy
ii  libc6 [glibc-2.3.2.ds1-16]  2.3.2.ds1-16 GNU C Library: Shared libraries an

-- debconf information:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "it_IT.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
* locales/default_environment_locale: it_IT@euro
* locales/locales_to_be_generated: it_IT.UTF-8@euro UTF-8, it_IT@euro ISO-8859-15

---------------------------------------
Received: (at 265493-done) by bugs.debian.org; 13 Aug 2004 12:31:51 +0000
>From gotom@debian.or.jp Fri Aug 13 05:31:51 2004
Return-path: <gotom@debian.or.jp>
Received: from omega.webmasters.gr.jp (webmasters.gr.jp) [218.44.239.78] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BvbDr-00025c-00; Fri, 13 Aug 2004 05:31:51 -0700
Received: from omega.webmasters.gr.jp (localhost [127.0.0.1])
	by webmasters.gr.jp (Postfix) with ESMTP
	id C6D6CDEB58; Fri, 13 Aug 2004 21:31:50 +0900 (JST)
Date: Fri, 13 Aug 2004 21:31:50 +0900
Message-ID: <81smar43t5.wl@omega.webmasters.gr.jp>
From: GOTO Masanori <gotom@debian.or.jp>
To: =?UTF-8?B?Tmljb2zvv73vv70=?= Wojewoda <nico@woje.it>,
	265493-done@bugs.debian.org
Subject: Re: Bug#265493: locales: getting always a warning message
In-Reply-To: <40F3EBEA007AC5A3@mail-relay-4.tiscali.it> (added by postmaster@mail-relay-4.tiscali.it)
	<40F3EBEA007AC5A3@mail-relay-4.tiscali.it> (added by postmaster@mail-relay-4.tiscali.it)
References: <40F3EBEA007AC5A3@mail-relay-4.tiscali.it>
User-Agent: Wanderlust/2.9.9 (Unchained Melody) SEMI/1.14.3 (Ushinoya)
 FLIM/1.14.3 (=?ISO-8859-4?Q?Unebigory=F2mae?=) APEL/10.3 Emacs/21.2
 (i386-debian-linux-gnu) MULE/5.0 (SAKAKI)
MIME-Version: 1.0 (generated by SEMI 1.14.3 - "Ushinoya")
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
Delivered-To: 265493-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 

At Fri, 13 Aug 2004 13:53:57 +0200,
Nicol=1B-b=C3=C2=B2 Wojewoda wrote:
> I always get (when installing, removing or reconfiguring packages) the wa=
rning message you can read under the "-- debconf information" label.
>=20
> -- System Information:
> Debian Release: 3.1
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: i386 (i686)
> Kernel: Linux 2.6.7-1-k7
> Locale: LANG=3Dit_IT.UTF-8, LC_CTYPE=3Dit_IT.UTF-8
>=20
> Versions of packages locales depends on:
> ii  debconf                     1.4.30       Debian configuration managem=
ent sy
> ii  libc6 [glibc-2.3.2.ds1-16]  2.3.2.ds1-16 GNU C Library: Shared librar=
ies an
>=20
> -- debconf information:
> perl: warning: Setting locale failed.
> perl: warning: Please check that your locale settings:
> 	LANGUAGE =3D (unset),
> 	LC_ALL =3D (unset),
> 	LANG =3D "it_IT.UTF-8"
>     are supported and installed on your system.
> perl: warning: Falling back to the standard locale ("C").
> locale: Cannot set LC_CTYPE to default locale: No such file or directory
> locale: Cannot set LC_MESSAGES to default locale: No such file or directo=
ry
> locale: Cannot set LC_ALL to default locale: No such file or directory
> * locales/default_environment_locale: it_IT@euro
> * locales/locales_to_be_generated: it_IT.UTF-8@euro UTF-8, it_IT@euro ISO=
-8859-15

Because you generated it_IT@euro, not it_IT.  Use it_IT.UTF-8@euro for
LANG.  Closed.

Regards,
-- gotom



Reply to: