[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#258647: libc6-sparc64 has no reason to depend on lib64gcc1

At Mon, 12 Jul 2004 09:17:27 +0400,
Nikita V. Youshchenko <yoush@cs.msu.su> wrote:
> > Nikita V. Youshchenko <yoush@cs.msu.su> wrote:
> > > Package: libc6-sparc64
> > > Version: 2.3.2.ds1-13
> > >
> > > Package libc6-sparc64 has no reason to depend on lib64gcc1. None of
> > > libraries provided by libc6-sparc64 are linked agains this library.
> >
> > The problem is they don't need to be installed on sparc environment
> > always.
> I can't understang how that's related to depending on lib64gcc1.
> None of libc6 packages on other architectures depends on libgcc packages.
> And libc6-s390x on s390 does not depend on lib64gcc1.
> There is no reason for libc6 to depend on libgcc.

Then is it safe to remove dependency?  If some userland application
need to use lib64gcc1, user has to install it manually?  debian-sparc
guys, BenC, is it OK?  Nikita, please ask to debian-sparc guys instead
of me.

-- gotom

Reply to: