[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#221706: segfault when reading package lists

On Wed, Nov 19, 2003 at 09:19:53AM -0800, Ken Treis wrote:

> Subject: /usr/lib/libapt-pkg-libc6.3-5.so.3.3: segfault when reading 
> package lists
> Package: apt
> Version: 0.5.14
> Severity: normal
> File: /usr/lib/libapt-pkg-libc6.3-5.so.3.3
> *** Please type your report below this line ***
> After an upgrade to the latest libc6, I get the following behavior when
> doing an `apt-get update`:
> [segfault]

Please send a copy of `diff -u /var/backups/dpkg.status.0
/var/lib/dpkg/status` (or whichever backup is dated prior to the upgrade).

Make a backup of /var/cache/apt/*.bin and delete them, then run apt-get
update again.  See if this fixes the problem.

I'm copying the glibc maintainers to see if this corresponds to a known bug.
This is a segfault in a C++ shared library on powerpc using libc6

 - mdz

Reply to: