[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#221215: glibc-doc: Missing versioned depend (or conflict) on dpkg

Package: glibc-doc
Version: 2.3.2.ds1-10
Severity: important

The post-install of this version of glibc-doc depends on some bugfix
present only in a later version of dpkg, but doesn't say so in its
depends / conflicts fields.

With dpkg 1.9.21, here is the error message one gets:

Setting up glibc-doc (2.3.2.ds1-10) ...
/var/lib/dpkg/info/glibc-doc.postinst: line 19: 23305 Segmentation fault      install-info --quiet --section "GNU C library functions" "GNU C library functions" /usr/share/info/libc-dir-add.info
dpkg: error processing glibc-doc (--configure):
 subprocess post-installation script returned error exit status 139

Once dpkg 1.10.18 is installed, post-install of glibc-doc goes well.

I didn't test intermediary versions of dpkg.

Please depend on a new-enough version of dpkg or conflict with too-old

-- System Information:
Debian Release: 3.0
Architecture: i386
Kernel: Linux tofu 2.4.20-usagi+devmap #1 mer avr 9 16:18:03 CEST 2003 i686
Locale: LANG=fr_LU@euro, LC_CTYPE=fr_LU@euro

-- no debconf information

Reply to: