[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#215463: libc6: Running /lib/libc-2.3.2.so gives ld.so error



Package: libc6
Version: 2.3.2-8
Severity: normal

As the subject says, when I run /lib/libc-2.3.2.so to try to see the
credits, I get instead:

Inconsistency detected by ld.so: rtld.c: 1175: dl_main: Assertion `_rtld_local._dl_rtld_map.l_prev->l_next == _rtld_local._dl_rtld_map.l_next' failed!

This seems to be causing fenris not to build from source (when running
pbuilder build fenris_0.07build3244-2.1.dsc, it gets the same error
while trying to determine the glibc version).

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux frobnitz 2.6.0-test4 #1 Thu Aug 28 00:56:57 PDT 2003 i686
Locale: LANG=C, LC_CTYPE=C

Versions of packages libc6 depends on:
ii  libdb1-compat                 2.1.3-7    The Berkeley database routines [gl

-- no debconf information


-- 
Daniel Schepler              "Please don't disillusion me.  I
schepler@math.berkeley.edu    haven't had breakfast yet."
                                 -- Orson Scott Card



Reply to: