[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#205234: marked as done (libc6: vsyslog() call hangs su and login)

Your message dated Sun, 21 Sep 2003 09:47:42 -0400
with message-id <E1A14Yw-00087F-00@auric.debian.org>
and subject line Bug#205234: fixed in glibc 2.3.2-8
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 13 Aug 2003 15:04:14 +0000
>From nmatantsev@hotmail.com Wed Aug 13 10:02:27 2003
Return-path: <nmatantsev@hotmail.com>
Received: from sea2-f20.sea2.hotmail.com (hotmail.com) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 19mx8t-0004L5-00; Wed, 13 Aug 2003 10:02:27 -0500
Received: from mail pickup service by hotmail.com with Microsoft SMTPSVC;
	 Wed, 13 Aug 2003 08:02:26 -0700
Received: from by sea2fd.sea2.hotmail.msn.com with HTTP;
	Wed, 13 Aug 2003 15:02:26 GMT
X-Originating-IP: []
X-Originating-Email: [nmatantsev@hotmail.com]
From: "Nikita Matantsev" <nmatantsev@hotmail.com>
To: submit@bugs.debian.org
Subject: libc6: vsyslog() call hangs su and login
Date: Wed, 13 Aug 2003 11:02:26 -0400
Mime-Version: 1.0
Content-Type: text/plain; format=flowed
Message-ID: <Sea2-F208qrkgCeR9eJ00012fb4@hotmail.com>
X-OriginalArrivalTime: 13 Aug 2003 15:02:26.0802 (UTC) FILETIME=[E8B58D20:01C361AB]
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_07_20 (

Package: libc6
Version: 2.3.2-2

After upgrading to this version of libc6 and rebooting, su or login do not 
work anymore.
su hangs after prompting for password (or right away, if invoked as root), 
regardless of whether the '-' option is given.

I am running Debian unstable; I tried this with at least 3 or 4 kernels. For 
kernels 2.2.25, 2.4.20, 2.4.21 I was able to successfully login using GDM; 
but su hung in all of them.

When I tried booting with the 2.6.0 testing kernel in unstable, I got a 
chance to try text console login (X server wouldn't start due to its own 
issues) - I could not login through console at all - login hung as well.

I also tried downgrading the login package, but that did not make any 

I ran su using gdb and after it hung and I sent SIGINT to the process, the 
backtrace was as follows:

#0  0x401e3b88 in __pthread_sigsuspend () from /lib/libpthread.so.0
#1  0x401e3999 in __pthread_wait_for_restart_signal () from 
/lib/libpthread.so.0#2  0x401e5159 in __pthread_alt_lock () from 
#3  0x401e24e6 in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x4011dead in vsyslog () from /lib/libc.so.6
#5  0x40180289 in _log_err () from /lib/security/pam_unix.so
#6  0x4017ead7 in pam_sm_open_session () from /lib/security/pam_unix.so
#7  0x4004c9c8 in pam_fail_delay () from /lib/libpam.so.0
#8  0x4004cb18 in _pam_dispatch () from /lib/libpam.so.0
#9  0x4004e516 in pam_open_session () from /lib/libpam.so.0
#10 0x0804a780 in ?? ()
#11 0x080568c8 in ?? ()

Googling revealed that the pthread calls look like something to do with an 
unitialized mutex, but that's just my guessing.

Downgrading libc6 to 2.3.1 fixed the problem.

This bug seems similar to bug #205099 - that one also involved a syslog call 
and a hanging process.



STOP MORE SPAM with the new MSN 8 and get 2 months FREE*   

Received: (at 205234-close) by bugs.debian.org; 21 Sep 2003 13:53:11 +0000
>From katie@auric.debian.org Sun Sep 21 08:53:09 2003
Return-path: <katie@auric.debian.org>
Received: from auric.debian.org [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1A14e9-00044j-00; Sun, 21 Sep 2003 08:53:05 -0500
Received: from katie by auric.debian.org with local (Exim 3.35 1 (Debian))
	id 1A14Yw-00087F-00; Sun, 21 Sep 2003 09:47:42 -0400
From: Philip Blundell <pb@debian.org>
To: 205234-close@bugs.debian.org
X-Katie: $Revision: 1.35 $
Subject: Bug#205234: fixed in glibc 2.3.2-8
Message-Id: <E1A14Yw-00087F-00@auric.debian.org>
Sender: Archive Administrator <katie@auric.debian.org>
Date: Sun, 21 Sep 2003 09:47:42 -0400
Delivered-To: 205234-close@bugs.debian.org

Source: glibc
Source-Version: 2.3.2-8

We believe that the bug you reported is fixed in the latest version of
glibc, which is due to be installed in the Debian FTP archive:

  to pool/main/g/glibc/glibc-doc_2.3.2-8_all.deb
  to pool/main/g/glibc/glibc_2.3.2-8.diff.gz
  to pool/main/g/glibc/glibc_2.3.2-8.dsc
  to pool/main/g/glibc/libc-udeb_2.3.2-8_i386.udeb
  to pool/main/g/glibc/libc6-dbg_2.3.2-8_i386.deb
  to pool/main/g/glibc/libc6-dev_2.3.2-8_i386.deb
  to pool/main/g/glibc/libc6-pic_2.3.2-8_i386.deb
  to pool/main/g/glibc/libc6-prof_2.3.2-8_i386.deb
  to pool/main/g/glibc/libc6_2.3.2-8_i386.deb
  to pool/main/g/glibc/locales_2.3.2-8_all.deb
  to pool/main/g/glibc/nscd_2.3.2-8_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 205234@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Philip Blundell <pb@debian.org> (supplier of updated glibc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed, 17 Sep 2003 20:44:48 +0100
Source: glibc
Binary: libc6.1-prof libc1 libc0.3-pic locales glibc-doc libc6-pic libc-udeb libc1-prof libc0.3 libc0.3-dbg libc6.1-dev libc1-pic libc6-s390x libc6-prof libc1-dbg libc6-dev-sparc64 libc6 libc0.3-dev libc6-dbg nscd libc6.1-dbg libc6.1-pic libc6-sparc64 libc6-dev libc0.3-prof libc6.1 libc6-dev-s390x libc1-dev
Architecture: source i386 all
Version: 2.3.2-8
Distribution: unstable
Urgency: low
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Changed-By: Philip Blundell <pb@debian.org>
 glibc-doc  - GNU C Library: Documentation
 libc-udeb  - GNU C Library: Shared libraries and Timezone data - udeb (udeb)
 libc6      - GNU C Library: Shared libraries and Timezone data
 libc6-dbg  - GNU C Library: Libraries with debugging symbols
 libc6-dev  - GNU C Library: Development Libraries and Header Files.
 libc6-pic  - GNU C Library: PIC archive library
 libc6-prof - GNU C Library: Profiling Libraries.
 locales    - GNU C Library: National Language (locale) data [support]
 nscd       - GNU C Library: Name Service Cache Daemon
Closes: 205234 210301 211135
 glibc (2.3.2-8) unstable; urgency=low
   * Phil Blundell <pb@debian.org>
     - debian/control.in/main: add gawk to Build-Depends, since testsuite
       apparently requires it.
     - debian/patches/pthread-cleanup.dpatch: Vector __pthread_cleanup_push
       and __pthread_cleanup_pop through __libc_pthread_functions.
       (Closes: #205234)
     - debian/patches/arm-no-hwcap.dpatch: Admit HWCAP_FAST_MULT again,
       since we want to start using this for openssh.
     - debian/patches/arm-updates.dpatch: Add some miscellaneous arm
       changes taken from upstream.
     - debian/patches/arm-vfork.dpatch: Avoid bad interaction between
       vfork and libpthread.
   * GOTO Masanori  <gotom@debian.org>
     - debian/patches/80_glibc232-fesetround-fix.dpatch: Fix fesetround static
       link time failure.  (Closes: #211135)
     - debian/patches/lo_LA.UTF-8_not_supported.dpatch: Dropped, to support
       lo_LA.UTF-8 again.
     - debian/patches/80_glibc232-locales-lo_LA.dpatch: Added to support
       lo_LA.UTF-8 again.
     - debian/locales/usr/sbin/locale-gen: Fix locale-gen breaks with bash
       2.03, unset POSIXLY_CORRECT iff it's previously defined.
       Patched by Daniel Verite <daniel@brainstorm.fr>.  (Closes: #210301)
 f3992dbcef29a645e5a4b64027565981 1684 libs required glibc_2.3.2-8.dsc
 2777f39352b0762105e4b42bcec575f8 1178096 libs required glibc_2.3.2-8.diff.gz
 9c0f14841ea4fec579a6dc86a9f1ceb3 3717572 base required libc6_2.3.2-8_i386.deb
 d4edda6aa25ca67c494dec277d01b4cb 1066086 debian-installer required libc-udeb_2.3.2-8_i386.udeb
 47cd8c1fce8913e868ee930367491c1d 2633324 libdevel standard libc6-dev_2.3.2-8_i386.deb
 c1b73aaef7ff64e73e5b6bd61f41420a 1027080 libdevel extra libc6-prof_2.3.2-8_i386.deb
 86f88c315d7410295e33b424a40053d5 8527672 libdevel extra libc6-dbg_2.3.2-8_i386.deb
 6f08f99dad3e773ca7f2040b77735788 997168 libdevel optional libc6-pic_2.3.2-8_i386.deb
 1498b580cc1ae118e01e755cdaf49657 77948 admin optional nscd_2.3.2-8_i386.deb
 b825730dcdafdb19fa366a83c0bd2eca 3799972 base standard locales_2.3.2-8_all.deb
 216fde46ac173740bf4ed351330990be 3705298 doc optional glibc-doc_2.3.2-8_all.deb

Version: GnuPG v1.2.3 (GNU/Linux)


Reply to: