[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#206522: libc-udeb: maybe should not provide glibc-2.3.2-2

At Thu, 21 Aug 2003 10:36:06 +0200,
thomas@poindessous.com wrote:
> Hi, today I tried to update the package "locales"
> $ sudo apt-get install -u -s locales
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following extra packages will be installed:
>   libc-udeb
> The following NEW packages will be installed:
>   libc-udeb
> The following packages will be upgraded
>   locales
> 1 packages upgraded, 1 newly installed, 0 to remove and 64 not upgraded.
> Inst libc-udeb (2.3.2-3 ftp.de.debian.org)
> Inst locales [2.3.2-2] (2.3.2-3 Debian:unstable)
> Conf libc-udeb (2.3.2-3 ftp.de.debian.org)
> Conf locales (2.3.2-3 Debian:unstable)
> My apt/sources.list looks like :
> deb http://ftp.oleane.net/pub/debian/ unstable main non-free contrib
> deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free
> deb http://security.debian.org/ stable/updates main contrib non-free
> deb http://ftp.de.debian.org/debian unstable main/debian-installer
> Maybe I'm missing something, should I use pinning for debian-installer ? 

I don't touch debian-installer yet, but I guess your apt-line has no
libc6 information?  Instead of libc6, apt-get try to provides
glibc-2.3.2-3 using libc-udeb.  Please confirm it.

> How could I have debian-installer in my sources.list without risking to
> install some udeb in my system ?

I recommend you to hear about this issue on debian-boot or d-i related

-- gotom

Reply to: