[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#186281: libc6 and libdb1-compat mutual dependency

On Wed, Mar 26, 2003 at 02:37:03PM +0900, GOTO Masanori wrote:
> At Tue, 25 Mar 2003 22:06:28 +0100,
> Tom Peters wrote:
> > After using a rescue disk and some manual copying and symlinking for 
> > the newer libc6, configuration was still impossible because of a
> > dependency conflict:
> > 
> > # dpkg --configure libc6
> > # dpkg --configure libdb1-compat
> Hmm, it's bad.  Circular dependency is happened here.

Why is this a problem? Tom, you should use 'dpkg --configure libc6
libdb1-compat'. I don't think there's a bug here.

> Colin, should we remove "depends: libc6" from libdb1-compat?

I don't think that would be correct. Depends: loops are supported, and
legitimate in this case: it is really true that neither libc6 nor
libdb1-compat will be configured correctly until both are configured
correctly, but dpkg knows how to break this loop as long as you give it
enough information, and apt has no problem with it.

A Pre-Depends: loop would be a problem, but we don't have that here.


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: