[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#184036: libc6: xscreensaver can no longer authenticate me

At 09 Mar 2003 14:51:10 -0500,
Anthony DeRobertis wrote:
> On Sun, 2003-03-09 at 01:55, GOTO Masanori wrote:
> > The point is that "no longer authenticate me" is really caused by
> > glibc.  Which versions do you upgrade from? 
> The one that was in testing until last night (2.2.5-14.3). 
> > I guess you also upgrade
> > many packages at the same time including X11.
> Nope, no X11 updates. There were other packages, but they aren't related
> to xscreensaver.
> > Please consolidate
> > whether it's glibc problem or not.
> Considering all the other sudden authentication failure bugs caused by
> the glibc 2.2 -> 2.3 transition, it seems quite probable.

You upgraded a lot of packages, though.

> Everything that does authentication needs to be restarted after the
> glibc upgrade, correct?

I think "yes".

So we're warning with libc6 upgrade in postinst.  Moreover, upgrading
libc6 from 2.2 to 2.3 (or upgrade everytime, ideally) should need
system restart.  Unfortunately, there is no way to fix it.

-- gotom

Reply to: