[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#183477: libc6's conflict against php4 is pretty much bogus and useless

At Tue, 04 Mar 2003 23:38:09 -0700,
Adam Conrad wrote:
> Package: libc6
> Version: 2.3.1-14
> Severity: normal
> libc6 has the following conflict: php4 (<< 4:4.2.3-5), to work around what
> appeared to be a linking bug in php4 in the 4.2.3 series of the packages.
> The versions of php4 in stable and testing (4:4.1.2-X) don't exhibit this
> problem, and the current versions in unstable don't either, so essentially
> this conflict makes partial upgrades more difficult for the sake of conflicting
> against a package that was never in a formal release and is no longer in the
> archive.
> The conflict can (should) be removed, and it certainly won't do any harm to
> do so at this point.

I don't know why this conflict was introduced.  It might be related
with __libc_fork bug (see #170385).  However, I introduced the patch
to fix __libc_fork issue, so I think this conflicts becomes
meaningless nowadays.

Jeff Bailey might know about it in detail.  Jeff, could I remove
conflicts: php4 and wine?

-- gotom

Reply to: