[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#174004: qmail can't run after update to 2.3.1-6

Package: libc6
Version: 2.3.1-6

After installing latest libc6 qmail failed to start with "alert: cannot start: 
unable to read controls".
strace qmail-smtpd suggest this is missing configuration file:

open("control/percenthack", O_RDONLY|O_NONBLOCK) = -1 ENOENT (No such file or 
write(0, "alert: cannot start: unable to r"..., 45alert: cannot start: unable 
to read controls
) = 45
_exit(111)                              = ?

but this configfile is optional and after downgrading libc6 + locales
to 2.3.1-5 all works O.K. Wery strange.
Maybe there is some memory corruption in new libc.

Petr Baláš (petr at balas dot cz)

Reply to: