[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

glibc 2.1 and texinfo

The INSTALL file for glibc 2.1 lists a bunch of programs that are needed
to compile (or configure) glibc 2.1 successfully.  texinfo is one of
those listed, and since my configure script was failing with a "one of
your programs is missing or too old" message when it got to checking
makeinfo (part of texinfo), I downloaded the texinfo package from the
gnu.org to install it. The configure script for texinfo worked fine but
teh compile was failing with a bunch of messages about "call to
unreferenced tputs and tgets functions".  the file that was making those
calls was terminal.c and it had some conditional includes for
termcap.h.  I found from the gnu site that tputs and tgets are part of
termcap, so what the heck, I downloaded that and went on to install it.
that one worked fine and I installed it(./configure, make, make install
- nothing else). after which texinfo actually compiled (same
./configure, make, make install).  so I happily went back to glibc,
typed ./configure adn damn it to hell it still didn't work. it fails
with the same message, the only difference being that when it gets to
checking makinfo, it says: checking for makeinfo - yes, instead of:
checking for makinfo - no.  The error message is right after that just
as before.
I am using debian 2.0 with a 2.2.4kernel.  I've installed everything
unitl now using dpkg adn packages from teh debian site (except for the
kernel and X).  My best guess is that something is misconfigured with
the texinfo installation, but I am not sure where to look from here. The
debian site didn't have a .deb package for texinfo which is why I went
with the one from gnu.org. If anyone has any ideas Id appreciate it.


				- Vladimir

Reply to: