[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

netcdf-fortran not building in pbuilder - wierd

Hi Bas,

I just tried a test build of netcdf-fortran with gbp buildpackage
(pbuilder) after pulling your latest commits, and it borks with the the

dpkg-source: info: building netcdf-fortran using existing
can't find file to patch at input line 6
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|Description: Use local logo image to fix privacy-breach-logo lintian error.
|Author: Bas Couwenberg <sebastic@xs4all.nl>
|--- a/docs/footer.html
|+++ b/docs/footer.html
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
dpkg-source: info: fuzz is not allowed when applying patches
dpkg-source: info: if patch 'privacy-breach-logo.patch' is correctly
applied by quilt, use 'quilt refresh' to update it
dpkg-source: error: LC_ALL=C patch -t -F 0 -N -p1 -u -V never -g0 -E -b
-B .pc/privacy-breach-logo.patch/ --reject-file=- <
netcdf-fortran-4.4.1.orig.L7MtPC/debian/patches/privacy-breach-logo.patch gave
error exit status 1
dpkg-buildpackage: error: dpkg-source -b netcdf-fortran-4.4.1 gave error
exit status 2
gbp:error: Couldn't run 'git-pbuilder': git-pbuilder returned 2

Thinking something was wrong with the merge my end, and knowing I hadn't
committed anything locally recently, I deleted the local clone and
re-cloned afresh. But it is still the same.

I refreshed the patches, then a git diff gives me:

$ git diff
diff --git a/debian/patches/hyphen-used-as-minus-sign.patch
index 00ff57b..4372762 100644
--- a/debian/patches/hyphen-used-as-minus-sign.patch
+++ b/debian/patches/hyphen-used-as-minus-sign.patch
@@ -3,9 +3,9 @@ Author: Bas Couwenberg <sebastic@xs4all.nl>
 Forwarded: https://github.com/Unidata/netcdf-fortran/pull/24

---- a/docs/netcdf_fortran.3
-+++ b/docs/netcdf_fortran.3
-@@ -11,10 +11,10 @@ netcdf \- Unidata's Network Common Data
+--- netcdf-fortran.orig/docs/netcdf_fortran.3
++++ netcdf-fortran/docs/netcdf_fortran.3
+@@ -11,10 +11,10 @@
  include netcdf.inc
  .SS Most Systems:

So dpkg-source complains about the privacy-breach-logo.patch, but quilt
refreshes the hyphen-used-as-minus-sign.patch, and you can see that it
contains netcdf-fortran.orig/docs/netcdf_fortran.3. The ".orig" looks
like something leftover from a merge, but I don't see the file anywhere.

$debuild -uc -us works fine.

Do you see the same? Any clues?



Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: