[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#686061: libffi5:armhf cannot be installed with libffi5:amd64



Package: libffi5
Version: 3.0.10-3+b1

woodpecker:~# aptitude install libsamplerate0-dev:armhf
The following NEW packages will be installed:
  libffi5:armhf{ab} libglib2.0-0:armhf{a} libpcre3:armhf{a} libpopt0:armhf{a} libsamplerate0:armhf{a} libsamplerate0-dev:armhf 
  libselinux1:armhf{a} pkg-config:armhf{ab} zlib1g:armhf{a} 
0 packages upgraded, 9 newly installed, 0 to remove and 9 not upgraded.
Need to get 5,191 kB of archives. After unpacking 7,613 kB will be used.
The following packages have unmet dependencies:
 pkg-config : Conflicts: pkg-config:armhf but 0.26-1+b1 is to be installed.
 pkg-config:armhf : Conflicts: pkg-config but 0.26-1 is installed.
 libffi5 : Breaks: libffi5:armhf (!= 3.0.10-3) but 3.0.10-3+b1 is to be installed.
 libffi5:armel : Breaks: libffi5:armhf (!= 3.0.10-3) but 3.0.10-3+b1 is to be installed.
 libffi5:armhf : Breaks: libffi5 (!= 3.0.10-3+b1) but 3.0.10-3 is installed.
                 Breaks: libffi5:armel (!= 3.0.10-3+b1) but 3.0.10-3 is installed.
                 Breaks: libffi5:i386 (!= 3.0.10-3+b1) but 3.0.10-3 is installed.
 libffi5:i386 : Breaks: libffi5:armhf (!= 3.0.10-3) but 3.0.10-3+b1 is to be installed.


There is no binary of libffi5 version 3.0.10-3+b1.  It is impossible
for me to install libffi5:armhf.


Reply to: