[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#649615: gdc-4.4: Annoying multilib warning

Package: gdc-4.4
Version: 1.063-4.4.6-7
Severity: important

Any invocation of the gdc-4.4 compiler prints a multilib-relted warning:

  cc1d: warning: command line option "-imultilib" is valid for
  C/C++/Fortran/ObjC/ObjC++ but not for D

This is rather annoying and hides useful compiler warnings.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=nl_BE.UTF-8, LC_CTYPE=nl_BE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gdc-4.4 depends on:
ii  g++-4.4            4.4.6-11      
ii  gcc-4.4-base       4.4.6-11      
ii  libc6              2.13-21       
ii  libgcc1            1:4.6.2-4     
ii  libgmp10           2:5.0.2+dfsg-2
ii  libmpfr4           3.1.0-3       
ii  libphobos-4.4-dev  1.063-4.4.6-7 
ii  libstdc++6         4.6.2-4       

gdc-4.4 recommends no packages.

gdc-4.4 suggests no packages.

-- no debconf information

Reply to: