[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#633365: marked as done (libppl-swi: Getting rid of unneeded *.la / emptying dependency_libs)



Your message dated Mon, 11 Jul 2011 07:05:21 +0000
with message-id <E1QgAYT-0002fb-MQ@franck.debian.org>
and subject line Bug#633365: fixed in ppl 0.11.2-4
has caused the Debian Bug report #633365,
regarding libppl-swi: Getting rid of unneeded *.la / emptying dependency_libs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
633365: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=633365
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libppl-swi
Version: 0.11.2-3
Severity: normal
User: codehelp@debian.org
Usertags: la-file-removal

To finish an old release goal from Squeeze, to comply with Policy
10.2 and to ease the introduction of MultiArch, I'm filing bugs
against packages which contain .la files which can be either removed
or stripped of the dependency_libs variable.

http://wiki.debian.org/ReleaseGoals/LAFileRemoval

http://lists.debian.org/debian-devel/2011/04/msg00055.html

http://lists.debian.org/debian-devel/2011/04/msg00199.html

Data has been obtained from the output of an automated script:

http://release.debian.org/~aba/la/current.txt

The output is best read in conjunction with the criteria from this
post to debian-devel:

http://lists.debian.org/debian-devel/2009/08/msg00808.html

To generate the list of packages, I've used:

grep -v depended-on current.txt |cut -d: -f1

The data is regularly updated but please accept my apologies if you
have made an upload which changes the situation since the data was
parsed.

libppl-swi (0.11.2-3) appears in this list as a source package
because one or more of the binary packages (usually -dev packages)
contain .la files.

In this case, the .la file is in libppl-swi:

/usr/lib/ppl/libppl_swiprolog.la

# Libraries that this one depends upon.
dependency_libs=' /usr/lib/libppl.la -L/usr/lib /usr/lib/libpwl.la /usr/lib/libgmpxx.la /usr/lib/libgmp.la'

In most cases, the .la file(s) can simply be removed as the process
behind this MBF has already identified that there are no further
dependencies using the .la file. In the unusual case that your
package uses libltdl directly, it is still necessary to empty the
dependency_libs part of all .la files remaining in the package.

If you believe that your package needs both the .la file and the
dependency_libs settings, please raise this on debian-devel for
clarification.

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

Attachment: pgp5kJaz2dbwx.pgp
Description: PGP signature


--- End Message ---
--- Begin Message ---
Source: ppl
Source-Version: 0.11.2-4

We believe that the bug you reported is fixed in the latest version of
ppl, which is due to be installed in the Debian FTP archive:

libppl-c4_0.11.2-4_amd64.deb
  to main/p/ppl/libppl-c4_0.11.2-4_amd64.deb
libppl-doc_0.11.2-4_all.deb
  to main/p/ppl/libppl-doc_0.11.2-4_all.deb
libppl-swi_0.11.2-4_amd64.deb
  to main/p/ppl/libppl-swi_0.11.2-4_amd64.deb
libppl0.11-dev_0.11.2-4_amd64.deb
  to main/p/ppl/libppl0.11-dev_0.11.2-4_amd64.deb
libppl9_0.11.2-4_amd64.deb
  to main/p/ppl/libppl9_0.11.2-4_amd64.deb
libpwl-dev_0.11.2-4_amd64.deb
  to main/p/ppl/libpwl-dev_0.11.2-4_amd64.deb
libpwl5_0.11.2-4_amd64.deb
  to main/p/ppl/libpwl5_0.11.2-4_amd64.deb
ppl_0.11.2-4.debian.tar.gz
  to main/p/ppl/ppl_0.11.2-4.debian.tar.gz
ppl_0.11.2-4.dsc
  to main/p/ppl/ppl_0.11.2-4.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 633365@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Tautschnig <mt@debian.org> (supplier of updated ppl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 10 Jul 2011 12:05:38 +0200
Source: ppl
Binary: libppl9 libppl0.11-dev libppl-c4 libpwl5 libpwl-dev libppl-doc libppl-swi
Architecture: source amd64 all
Version: 0.11.2-4
Distribution: unstable
Urgency: low
Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Changed-By: Michael Tautschnig <mt@debian.org>
Description: 
 libppl-c4  - Parma Polyhedra Library (C interface)
 libppl-doc - Parma Polyhedra Library: Documentation
 libppl-swi - Parma Polyhedra Library (SWI Prolog interface)
 libppl0.11-dev - Parma Polyhedra Library (development)
 libppl9    - Parma Polyhedra Library (runtime library)
 libpwl-dev - Parma Watchdog Library (Watchdog timers - development)
 libpwl5    - Parma Watchdog Library (Watchdog timers - runtime library)
Closes: 625417 633365
Changes: 
 ppl (0.11.2-4) unstable; urgency=low
 .
   * Patch away unused variables. Closes: #625417.
   * Don't ship libppl_swiprolog.la. Closes: #633365.
Checksums-Sha1: 
 b8604b8bcd3e424986c92b45550a27b618e02045 1348 ppl_0.11.2-4.dsc
 fa567cbb7d0ced408163ed4a5108a476a530daa0 306250 ppl_0.11.2-4.debian.tar.gz
 8bb62596cb22ec07c63c07c07ab3243f390ecb9a 530962 libppl9_0.11.2-4_amd64.deb
 9de370f1d87fc343e302a2620ef7bd73253e5fc2 3346812 libppl0.11-dev_0.11.2-4_amd64.deb
 2c2dee41dd3d8f795683c6fb5adfb75ff222a39b 1521486 libppl-c4_0.11.2-4_amd64.deb
 fdb91f8e767d89e9945b6c81852f562447ec2fe6 29804 libpwl5_0.11.2-4_amd64.deb
 705db34ac1d8a865a4c8602a51dd0ffc79982340 39274 libpwl-dev_0.11.2-4_amd64.deb
 56f69df6b80be23e4946baa415c3327c1a3cb98d 7623266 libppl-swi_0.11.2-4_amd64.deb
 32cce2886c8aca92ccc0fb98d17bb6bcf410dcbc 4439878 libppl-doc_0.11.2-4_all.deb
Checksums-Sha256: 
 c19fb095841e609d1c9652aeae921b5b992124f120f50f4e7186a1e115575a4a 1348 ppl_0.11.2-4.dsc
 922a0c875cc0f1894fdb74375ceff7667c3425dbdc296f05abdcb1129197015c 306250 ppl_0.11.2-4.debian.tar.gz
 be04928afe5c589dac08e27b718a9a8fc2252308717b0185a5da2983d52a1af6 530962 libppl9_0.11.2-4_amd64.deb
 1cf707a190dddd11276f7ee9dbdc512d7853fb48bc5d7f1eea604e0e5243a71d 3346812 libppl0.11-dev_0.11.2-4_amd64.deb
 d51c8d3591e3bb289c96ab2c5c00872de5e3e54ca21001c9047dec76fc49cb8d 1521486 libppl-c4_0.11.2-4_amd64.deb
 57772b8d950fb78396e896181a05b156f66f774edfe2dc593078fbb5f768eb62 29804 libpwl5_0.11.2-4_amd64.deb
 4e45a0433e5b84daa8a973ceecd349f754f245142f6f60ad4cf810c09e9a3e50 39274 libpwl-dev_0.11.2-4_amd64.deb
 cefd29197ee1a95d335256d4608082d1cf5d76d621bd36d8caae0d29f67f3e2c 7623266 libppl-swi_0.11.2-4_amd64.deb
 3a521fbcf82d914b66431002ae4d7e17e7c61e16d539b8234267c2906ba8a7b2 4439878 libppl-doc_0.11.2-4_all.deb
Files: 
 3af0e54443d378e0f9c74b55ea7815d8 1348 libs optional ppl_0.11.2-4.dsc
 b65229f7c2015ef7a6df619ec52a5d35 306250 libs optional ppl_0.11.2-4.debian.tar.gz
 dd70a489c1914cae572dd0aead39395c 530962 libs optional libppl9_0.11.2-4_amd64.deb
 9330a0272acb9f00b777e9bd8f51c301 3346812 libdevel optional libppl0.11-dev_0.11.2-4_amd64.deb
 807fd5dd20806ba97f35d24de09cde67 1521486 libs optional libppl-c4_0.11.2-4_amd64.deb
 d5bfe67b8b08c3176df0374b1233c894 29804 libs optional libpwl5_0.11.2-4_amd64.deb
 3a72dfec943e6333a4af9b85f73719e4 39274 libdevel optional libpwl-dev_0.11.2-4_amd64.deb
 d1d3cf344879012ee363742893763baf 7623266 libs optional libppl-swi_0.11.2-4_amd64.deb
 d12d98a7b9cc7720a8e6357b75d6119b 4439878 doc optional libppl-doc_0.11.2-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk4anNQACgkQvx6dH3bVKsSIXgCffTzY3qvO/9IYhtuWwLZxAJmp
g24AnR8cr2bU/jgiCkWvSWwnEHVIOjuV
=G8Mm
-----END PGP SIGNATURE-----



--- End Message ---

Reply to: