[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#622976: marked as done (libffi-dev: ffi.h in wrong directory on i386)

Your message dated Mon, 18 Apr 2011 23:03:26 +0000
with message-id <E1QBxTa-0005J8-4J@franck.debian.org>
and subject line Bug#622976: fixed in libffi 3.0.9-4
has caused the Debian Bug report #622976,
regarding libffi-dev: ffi.h in wrong directory on i386
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

622976: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622976
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libffi-dev
Version: 3.0.9-3
Severity: grave
Justification: renders package unusable

On i386:

$ dpkg-query -W cpp-4.5
cpp-4.5	4.5.2-9

$ echo '#include <ffi.h>' | cpp-4.5 > /dev/null
<stdin>:1:17: fatal error: ffi.h: No such file or directory
compilation terminated.

This breaks compilation of (at least) pygobject.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.38-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages libffi-dev depends on:
ii  dpkg                   Debian package management system
ii  libffi5                       3.0.9-3    Foreign Function Interface library

Jakub Wilk

--- End Message ---
--- Begin Message ---
Source: libffi
Source-Version: 3.0.9-4

We believe that the bug you reported is fixed in the latest version of
libffi, which is due to be installed in the Debian FTP archive:

  to main/libf/libffi/lib32ffi-dev_3.0.9-4_amd64.deb
  to main/libf/libffi/lib32ffi5_3.0.9-4_amd64.deb
  to main/libf/libffi/libffi-dev_3.0.9-4_amd64.deb
  to main/libf/libffi/libffi5-dbg_3.0.9-4_amd64.deb
  to main/libf/libffi/libffi5_3.0.9-4_amd64.deb
  to main/libf/libffi/libffi_3.0.9-4.diff.gz
  to main/libf/libffi/libffi_3.0.9-4.dsc

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 622976@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matthias Klose <doko@debian.org> (supplier of updated libffi package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 18 Apr 2011 21:50:12 +0200
Source: libffi
Binary: libffi-dev lib32ffi-dev lib64ffi-dev libn32ffi-dev libffi5 lib32ffi5 lib64ffi5 libn32ffi5 libffi5-dbg
Architecture: source amd64
Version: 3.0.9-4
Distribution: unstable
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Changed-By: Matthias Klose <doko@debian.org>
 lib32ffi-dev - Foreign Function Interface library (development files, 32bit)
 lib32ffi5  - Foreign Function Interface library runtime (32bit)
 lib64ffi-dev - Foreign Function Interface library (development files, 64bit)
 lib64ffi5  - Foreign Function Interface library runtime (64bit)
 libffi-dev - Foreign Function Interface library (development files)
 libffi5    - Foreign Function Interface library runtime
 libffi5-dbg - Foreign Function Interface library runtime (debug symbols)
 libn32ffi-dev - Foreign Function Interface library (development files, n32)
 libn32ffi5 - Foreign Function Interface library runtime (n32)
Closes: 622976
 libffi (3.0.9-4) unstable; urgency=low
   * Install to the multiarch triplet directories, not the gnu triplet
     directories (Steve Langasek). Closes: #622976.
 4e8f17d2d3cd5b524af6eeb1b2df397b565a3c96 1319 libffi_3.0.9-4.dsc
 1dd725b66b0fee80f88b20da82e0bf5189b2add4 8117 libffi_3.0.9-4.diff.gz
 b982d9482eb24647e255fc5c296f5183769dbcac 102202 libffi-dev_3.0.9-4_amd64.deb
 b2e223daec23c0913441ca0a5cb741d09601ca98 28942 lib32ffi-dev_3.0.9-4_amd64.deb
 d30cf5497968ed506191821cbb1d15426239182d 20236 libffi5_3.0.9-4_amd64.deb
 6f8299b7ba6fc7b19433a5fff523a6cecf856b2f 16402 lib32ffi5_3.0.9-4_amd64.deb
 29c80a41118bede638975d109d3a0011711ac4c8 64340 libffi5-dbg_3.0.9-4_amd64.deb
 6dd270134cb73a3f31292766f4bffa738921c72e315357a0235adfe2d485c601 1319 libffi_3.0.9-4.dsc
 6081180913612b2619ae734b47992bb86f8102fe80427db154689e6f4db04910 8117 libffi_3.0.9-4.diff.gz
 10f187d8235c5341b98a14e85bf5532b1a5dcdc8a227bb667e7c8e43761d2fe4 102202 libffi-dev_3.0.9-4_amd64.deb
 abc772e66e85386550fe2f574eb29107db8b50ef00467e9222f70225213580b6 28942 lib32ffi-dev_3.0.9-4_amd64.deb
 889d52c2ea411aeac2afa163b7e6bde860dc52fc6e21b2ede85b6990b16cd4d9 20236 libffi5_3.0.9-4_amd64.deb
 cb3306821674e2b288051f8bef7eacbb9cd482e6adedef043c772ff9d74ae501 16402 lib32ffi5_3.0.9-4_amd64.deb
 b2d44453e3df3c7827a60ea215dfdf5e5a260ec18f57857ce6c0e719eb9048be 64340 libffi5-dbg_3.0.9-4_amd64.deb
 14f895b664e1bf7e8d3b3e11f66c49bc 1319 libs optional libffi_3.0.9-4.dsc
 69cb19d1991bcc05634b6580a128922c 8117 libs optional libffi_3.0.9-4.diff.gz
 b328bdc366e866eb8e6707c292299f9c 102202 libdevel optional libffi-dev_3.0.9-4_amd64.deb
 0546b097028f0865477e08dfb87a8239 28942 libdevel extra lib32ffi-dev_3.0.9-4_amd64.deb
 0517d92c4940984fb30b9bb203d34fca 20236 libs optional libffi5_3.0.9-4_amd64.deb
 bfd6ed8a52b6c490e6c10dda6b7bc8c9 16402 libs extra lib32ffi5_3.0.9-4_amd64.deb
 1258e82dce25f475a9e6f81411ae9856 64340 debug extra libffi5-dbg_3.0.9-4_amd64.deb
Original-Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>

Version: GnuPG v1.4.11 (GNU/Linux)


--- End Message ---

Reply to: