[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#608055: g++-4.4: Segfault with GCC 4.4 when C++ .so is dlopen'd by pure-C, executable (GCC 4.3 and 4.5 unaffected)

retitle 608055 g++-4.4: Segfault in libstdc++ when C++ .so is dlopen'd
by pure-C executable

Further testing reveals that linking with g++-4.3 is *not* (or no longer
is) a workaround.
Running the linked program (in my case Audacious) with export
LD_PRELOAD=/usr/lib/libstdc++.so.6, however, *is* a workaround.

Here are further reports of this bug:


Please, can we get a fix for this?

John Lindgren

Reply to: