[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582876: gdc-4.3 needs tighter versioned dependency on gcc-4.3-base

On 25.05.2010 21:06, Stefan Fritsch wrote:
On Tuesday 25 May 2010, Iain Buclaw wrote:
On 24 May 2010 19:21, Stefan Fritsch<sf@sfritsch.de>  wrote:
On Monday 24 May 2010, Matthias Klose wrote:
On 24.05.2010 12:35, Stefan Fritsch wrote:
Package: gdc-4.3
Version: 1:1.046-4.3.4-5
Severity: serious

gdc 4.3.4 does not work with gcc-4.3-base 4.3.5:
I think you forgot to give an explanation why you closed this
bug. Or was the closing done by accident?

The upgrade to 4.3.5 has only been done this weekend, and gcc has
to be compiled and uploaded first before gdc can be built against

As for the bumping of gdc, has only been recently done, see link
for current status.

When it is uploaded for your architecture, update the package, then
try again. If problems persist, don't hesitate to reply back.

With the update, gdc works again. But the problem will re-appear with
gcc-4.3-base 4.3.6, unless you either change the dependencies or ship
the old symlink (4.3.5 ->  4.3), too. Therefore I think this bug is
still valid.

wrong. we should have kept the 4.3.4 symlink in the gcc-4.3 4.3.5-1 upload instead. no need to change this now.

Reply to: