[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#533033: gcc-4.4: gcc and g++ do not find their cc1 and cc1plus binaries



Package: gcc-4.4
Version: 4.4.0-6
Severity: grave
Justification: renders package unusable

gcc-4.4 and g++-4.4 cannot find their cc1 and cc1plus binaries
(respectively) - I am currently still working with 4.4.0-4 - as it seems
the only package version usable (I tested with 4.4.0-1, -3, -4, -5 and
-6) but all other than -1 seem not to find their files.

I did an strace run on 4.4.0-6 of the command

  gcc-4.4 --help=optimizers"


[...]
close(3)                                = 0
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/libexec/gcc/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/libexec/gcc/x86_64-linux-gnu/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/../../../../x86_64-linux-gnu/bin/x86_64-linux-gnu/4.4.0/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
stat("/usr/lib/gcc/x86_64-linux-gnu/4.4.0/../../../../x86_64-linux-gnu/bin/cc1", 0x7fff61a86a80) = -1 ENOENT (No such file or directory)
vfork(gcc-4.4: error trying to exec 'cc1': execvp: No such file or directory
)                                 = 24385
[...]


the cc1 binary is located in /usr/lib/gcc/x86_64-linux-gnu/4.4 where
only the symlink /usr/lib/gcc/x86_64-linux-gnu/4.4.1 points to.

The only files in the path /usr/lib/gcc/x86_64-linux-gnu/4.4.0 is:

  $ ls -l /usr/lib/gcc/x86_64-linux-gnu/4.4.0
  total 4
  drwxr-xr-x 2 root root 4096 2009-01-12 16:17 finclude

Anyone else having seen this?

Kind regards,
Marcus Fritzsch


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-3 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gcc-4.4 depends on:
ii  binutils                      2.19.1-1   The GNU assembler, linker and bina
ii  cpp-4.4                       4.4.0-6    The GNU C preprocessor
ii  gcc-4.4-base                  4.4.0-6    The GNU Compiler Collection (base 
ii  libc6                         2.9-13     GNU C Library: Shared libraries
ii  libgcc1                       1:4.4.0-6  GCC support library
ii  libgomp1                      4.4.0-6    GCC OpenMP (GOMP) support library

Versions of packages gcc-4.4 recommends:
ii  libc6-dev                     2.9-13     GNU C Library: Development Librari

Versions of packages gcc-4.4 suggests:
pn  gcc-4.4-doc                   <none>     (no description available)
ii  gcc-4.4-locales               4.4.0-4    The GNU C compiler (native languag
ii  gcc-4.4-multilib              4.4.0-6    The GNU C compiler (multilib files
pn  libgcc1-dbg                   <none>     (no description available)
pn  libgomp1-dbg                  <none>     (no description available)
ii  libmudflap0-4.4-dev           4.4.0-6    GCC mudflap support libraries (dev
ii  libmudflap0-dbg               4.4.0-6    GCC mudflap shared support librari

-- no debconf information



Reply to: