[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#523936: gcc-snapshot: please support ARMv4 like gcc-4.3 does

Package: gcc-snapshot
Version: 20090224-1
Severity: wishlist

[ X-Debbugs-Cc: pkg-fso-maint@lists.alioth.debian.org set since they
might hit this. ]

Trying to compile hello world on openmoko neo freerunner fails

$ cat > hello.c <<EOF
#include <stdio.h>

int main(int argc, char *argv[]) {
    puts("Hello world");
    return 0;
$ /usr/lib/gcc-snapshot/bin/gcc -o hello hello.c
Illegal instruction

apparently since

Program received signal SIGILL, Illegal instruction.
0x00009a48 in ?? ()
(gdb) bt
#0  0x00009a48 in ?? ()
#1  0x0000a2a8 in ?? ()
#2  0x000133a0 in ?? ()
#3  0x4005b03c in __libc_start_main () from /lib/libc.so.6
#4  0x0000944c in ?? ()
Cannot access memory at address 0x0
(gdb) x/5i $pc
0x9a48: blx     r10
0x9a4c: cmp     r0, #0  ; 0x0
0x9a50: bne     0x9a84
0x9a54: ldr     r3, [r4, #8]
0x9a58: cmp     r3, #2  ; 0x2

tries to execute a BLX instruction which is not supported in ARMv4. ARM
architecture reference manual page 113, section A3.3 says that BLX
with register operand is only available in ARMv5 and above. Could
please consider compiling gcc-snapshot with support for also ARMv4
like the gcc-4.3 package does?

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: armel (armv4tl)

Kernel: Linux 2.6.28-GTA02_lindi-andy-tracking_b8b36e5ec3db71d5-mokodev (PREEMPT)
Locale: LANG=C, LC_CTYPE=fi_FI (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/dash

Versions of packages gcc-snapshot depends on:
ii  binutils               2.19.1-1          The GNU assembler, linker and bina
ii  libasound2             1.0.19-1          shared library for ALSA applicatio
ii  libatk1.0-0            1.24.0-2          The ATK accessibility toolkit
ii  libc6                  2.9-7             GNU C Library: Shared libraries
ii  libc6-dev              2.9-7             GNU C Library: Development Librari
ii  libcairo2              1.8.6-2+b1        The Cairo 2D vector graphics libra
ii  libcloog-ppl0          0.15-1            the Chunky Loop Generator (runtime
ii  libfontconfig1         2.6.0-3           generic font configuration library
ii  libfreetype6           2.3.9-4           FreeType 2 font engine, shared lib
ii  libglib2.0-0           2.20.1-1          The GLib library of C routines
ii  libgmp3c2              2:4.2.4+dfsg-2    Multiprecision arithmetic library
ii  libgmpxx4ldbl          2:4.2.4+dfsg-2    Multiprecision arithmetic library 
ii  libgtk2.0-0            2.14.7-5          The GTK+ graphical user interface 
ii  libice6                2:1.0.5-1         X11 Inter-Client Exchange library
ii  libmpfr1ldbl           2.4.1-1           multiple precision floating-point 
ii  libpango1.0-0          1.24.0-3          Layout and rendering of internatio
ii  libppl-c2              0.10-4            Parma Polyhedra Library (C interfa
ii  libppl7                0.10-4            Parma Polyhedra Library (runtime l
ii  libsm6                 2:1.1.0-2         X11 Session Management library
ii  libxrandr2             2:1.3.0-2         X11 RandR extension library
ii  libxrender1            1:0.9.4-2         X Rendering Extension client libra
ii  libxtst6               2:1.0.3-1         X11 Testing -- Resource extension 
ii  zlib1g                 1: compression library - runtime

gcc-snapshot recommends no packages.

gcc-snapshot suggests no packages.

-- no debconf information

Reply to: