[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#479115: libffi4 is stopping the upgrade to gcc 4.3 4.3.0-4

Package: libffi4
Version: 4.3.0-3
Followup-For: Bug #479115


the original submitter of this  bug marked it as wontfix.
But I think that this bug should be addressed somehow.

There are 25 packages that directly rdepend on libffi4, and removing
libffi4 has a huge usability impact on a 'unstable' install ... 
thru all dependencies, you have to uninstall almost all of gnome.

I see two solutions to this lock.

1) Upload a new, separate version of libffi4  that would not
 depend on gcc-4.3-base (= 4.3.0-3)

2)  BINNMU of all above 25 packages.
In this latter case, you must be sure that all bbuildds
 are running  4.3.0-4   - when I uploaded mplayer on2008-05-03,
 this was not the case yet.
IN particular, I am worried: maybe there is some
 rdependecy that is stopping bbuildd's from upgrading to  4.3.0-4 ;
 in that case, the only way to solve this lock is (1).


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.25-1-686 (SMP w/1 CPU core)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libffi4 depends on:
ii  gcc-4.3-base                  4.3.0-3    The GNU Compiler Collection (base 
ii  libc6                         2.7-10     GNU C Library: Shared libraries

libffi4 recommends no packages.

-- no debconf information

Andrea Mennucc
 "E' un mondo difficile. Che vita intensa!" (Tonino Carotone)

Reply to: