[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc built with gcc-4.1 (update)

Aurelien Jarno a écrit :
Hi all,

As gcc-4.1 may be the default compiler soon (I hope so), I have tried to build the glibc with it.

Currently it builds and works on the following architectures:
amd64, hppa, i386, mips, mipsel, sparc

The packages are available [1], but a but outdated. It should not be a problem, as the changes are not so important between this version and the current one. It would be nice if some other people could test them, so the problems (if any) could be fixed.

It fails to build on powerpc, but I haven't investigated the problem yet.

I have fixed the problem, it now builds ok on powerpc. The packages are on available on [1]. They work fine on my machine.

I will build it on arm as soon as I get back home, as my machine is currently down.

I am looking for people to build an test it on alpha, ia64, m68k and s390. The source is available on the same place as the binaries [1].

glibc builds fine with gcc-4.1 on s390, but I haven't tested the resulting packages, they are available on [1]. The testsuite looks ok.

On arm, ia64 and alpha the glibc fails to build with gcc-4.1. I haven't found the time to investigate the problems now, but a quick look seems to say that on arm this is a glibc problem, whereas I suspect a problem with gcc-4.1 on ia64 and alpha. More to come as soon as I find some time...

I haven't done a build on m68k yet.

[1] http://people.debian.org/~aurel32/glibc

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: