[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#329848: stripclub: FTBFS on hppa

Steve Langasek wrote:

>>The fact that this only fails on hppa is rather odd, and is probably
>>worthy of a closer look.
>Sure.  Test it on other architectures, and see if it still builds -- judging
>by the timestamps, I think hppa is the only arch that's tried it since the
>new binutils hit the archive, so it's a fair assumption that it's not
>actually hppa-specific.
Looking at the timestamps, from what I can tell it looks like it's been
doing this for a while, and seems to be hppa specific (although the
error used to be 'file truncated'). I *just* tested rebuilding it on my
i386 box, using the latest sid packages, and it worked fine, so I'm not
sure why it's failing on hppa buildd. I don't have any other
architectures available to me.

Is there any documentation on whether or not compiling into /dev/null is
supported, or is this undocumented behavior that just happens to work on
everything BUT hppa? Seems like it's worth asking the gcc guys, so I'm
forwarding this to the gcc list.

In the mean time, I'll twiddle with the build scripts tomorrow and send
in a new package that should compile on hppa. I've known about this for
quite some time, but really had no idea what was causing it, so I just
kinda left it alone, hoping it was some hppa bug that would just get
fixed later.

Reply to: