[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#318865: odbc-postgresql: Segfault when running ODBC describe, amd64 client

Hash: SHA1

On Wednesday, 07.09.2005 at 23:00 +0200, Falk Hueffner wrote:

> can this problem be still reproduced with a newer gcc version such as
> 4.0? Is it possible to make a standalone test case?

I've just tested this out.  I only have a single, production amd64
system and so I did this using a chroot.  I bootstrapped Sarge into the
chroot, and then added the Etch sources to /etc/apt/sources.list in
order to enable me to install gcc 4.0.

First rebuild resulted in lots of unhappiness during dpkg-buildpackage
including "Unknown gcc system type x86_64-linux-gnu" at which point I
realised that gcc 4.0 in Etch uses libc6 2.3.5, which is newer than
Sarge.  So, I restarted and just made an Etch chroot instead :-)

Building the odbc-postgresl package in a minimal Etch environment using
gcc 4.0 resulted in a working package as the end product, but there were
a very large number of warngings during the compilation:

    info.c: In function 'PGAPI_Tables':
    info.c:1364: warning: pointer targets in passing argument 4 of 'schema_strcat1' differ in signedness
    info.c:1364: warning: pointer targets in passing argument 6 of 'schema_strcat1' differ in signedness
    info.c:1366: warning: pointer targets in passing argument 4 of 'my_strcat1' differ in signedness
    info.c:1367: warning: pointer targets in passing argument 4 of 'my_strcat1' differ in signedness    ...

    (lots of the same, I will post in its entirety if required, but I
    suspect the warnings are due to the strictness of gcc 4.0?)

Given that there were lots of warnings but no actual errors, I installed
this package into the Etch chroot and there was no segfault after
running the previously-described 'isql' tests using this version.

However, this working version of the package cannot be used in Sarge,
because of the libc6 dependency:

    Unpacking replacement odbc-postgresql ...
    dpkg: dependency problems prevent configuration of odbc-postgresql:
     odbc-postgresql depends on libc6 (>= 2.3.5-1); however:
      Version of libc6 on system is 2.3.2.ds1-22.
    dpkg: error processing odbc-postgresql (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:

The bug remains in the Sarge version of course, but that would appear to
be a compiler bug in gcc 3.3.

- -- 
Dave Ewart
Computing Manager, Cancer Epidemiology Unit
Cancer Research UK / Oxford University
PGP: CC70 1883 BD92 E665 B840 118B 6E94 2CFD 694D E370
Get key from http://www.ceu.ox.ac.uk/~davee/davee-ceu-ox-ac-uk.asc
N 51.7518, W 1.2016
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: