[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#317268: marked as done (g++-4.0: Assembler problem with g++-4.0)



Your message dated Tue, 12 Jul 2005 20:39:00 +0200
with message-id <17108.3652.926941.350484@gargle.gargle.HOWL>
and subject line Bug#317268: g++-4.0: Assembler problem with g++-3.4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 7 Jul 2005 08:44:18 +0000
>From beynet@fresnes.info Thu Jul 07 01:44:18 2005
Return-path: <beynet@fresnes.info>
Received: from fresnes.info (smtp.fresnes.info) [213.41.174.244] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DqRzV-0002l8-00; Thu, 07 Jul 2005 01:44:18 -0700
Received: by smtp.fresnes.info (Postfix, from userid 1000)
	id A4A1B19C06F; Thu,  7 Jul 2005 10:44:15 +0200 (CEST)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Yannick Beynet <beynet@fresnes.info>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: g++-4.0: Assembler problem with g++-3.4
X-Mailer: reportbug 3.15
Date: Thu, 07 Jul 2005 10:44:15 +0200
Message-Id: <20050707084415.A4A1B19C06F@smtp.fresnes.info>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-Spam-Level: 

Package: g++-4.0
Version: 4.0.0-12
Severity: important

When I Try to compile with g++-4.0 I have some assembler messages like
this :
tmp/cceXLCbg.s: Assembler messages:
/tmp/cceXLCbg.s:615: Warning: ignoring changed section attributes for
.gnu.linkonce.t._ZNSt12_Vector_baseISsSaISsEED2Ev
/tmp/cceXLCbg.s:719: Warning: ignoring changed section attributes for
.gnu.linkonce.t._ZNSt6vectorISsSaISsEED1Ev
/tmp/cceXLCbg.s:829: Warning: ignoring changed section attributes for
.gnu.linkonce.t._ZN5Utils15MimeContentTypeD2Ev

If I try to compile with g++-3.4 -> no more problem

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)

Versions of packages g++-4.0 depends on:
ii  gcc-4.0                     4.0.0-12     The GNU C compiler
ii  gcc-4.0-base                4.0.0-12     The GNU Compiler Collection (base 
ii  libc6                       2.3.2.ds1-22 GNU C Library: Shared libraries an
ii  libstdc++6-4.0-dev          4.0.0-12     The GNU Standard C++ Library v3 (d

g++-4.0 recommends no packages.

-- no debconf information

---------------------------------------
Received: (at 317268-done) by bugs.debian.org; 12 Jul 2005 18:39:07 +0000
>From doko@cs.tu-berlin.de Tue Jul 12 11:39:06 2005
Return-path: <doko@cs.tu-berlin.de>
Received: from mail.cs.tu-berlin.de [130.149.17.13] (root)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DsPes-0003yd-00; Tue, 12 Jul 2005 11:39:06 -0700
Received: from mailhost.cs.tu-berlin.de (postfix@mail.cs.tu-berlin.de [130.149.17.13])
	by mail.cs.tu-berlin.de (8.9.3p2/8.9.3) with ESMTP id UAA14716;
	Tue, 12 Jul 2005 20:39:04 +0200 (MEST)
Received: from localhost (localhost [127.0.0.1])
	by mailhost.cs.tu-berlin.de (Postfix) with ESMTP id A5644FC60;
	Tue, 12 Jul 2005 20:39:03 +0200 (MEST)
Received: from mailhost.cs.tu-berlin.de ([127.0.0.1])
 by localhost (bueno [127.0.0.1]) (amavisd-new, port 10224) with ESMTP
 id 00583-14; Tue, 12 Jul 2005 20:39:01 +0200 (MEST) 11336
Received: from bolero.cs.tu-berlin.de (bolero.cs.tu-berlin.de [130.149.19.1])
	by mailhost.cs.tu-berlin.de (Postfix) with ESMTP;
	Tue, 12 Jul 2005 20:39:01 +0200 (MEST)
Received: (from doko@localhost)
	by bolero.cs.tu-berlin.de (8.12.10+Sun/8.12.8/Submit) id j6CId1nf003712;
	Tue, 12 Jul 2005 20:39:01 +0200 (MEST)
From: Matthias Klose <doko@cs.tu-berlin.de>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Message-ID: <17108.3652.926941.350484@gargle.gargle.HOWL>
Date: Tue, 12 Jul 2005 20:39:00 +0200
To: Yannick Beynet <beynet@fresnes.info>, 317268-done@bugs.debian.org
Cc: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Re: Bug#317268: g++-4.0: Assembler problem with g++-3.4
In-Reply-To: <20050707084415.A4A1B19C06F@smtp.fresnes.info>
References: <20050707084415.A4A1B19C06F@smtp.fresnes.info>
X-Mailer: VM 7.17 under 21.4 (patch 17) "Jumbo Shrimp" XEmacs Lucid
X-Virus-Scanned: by amavisd-new at cs.tu-berlin.de
Delivered-To: 317268-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-Spam-Level: 
X-CrossAssassin-Score: 2

fixed with binutils-2.16.1

Yannick Beynet writes:
> Package: g++-4.0
> Version: 4.0.0-12
> Severity: important
> 
> When I Try to compile with g++-4.0 I have some assembler messages like
> this :
> tmp/cceXLCbg.s: Assembler messages:
> /tmp/cceXLCbg.s:615: Warning: ignoring changed section attributes for
> .gnu.linkonce.t._ZNSt12_Vector_baseISsSaISsEED2Ev
> /tmp/cceXLCbg.s:719: Warning: ignoring changed section attributes for
> .gnu.linkonce.t._ZNSt6vectorISsSaISsEED1Ev
> /tmp/cceXLCbg.s:829: Warning: ignoring changed section attributes for
> .gnu.linkonce.t._ZN5Utils15MimeContentTypeD2Ev
> 
> If I try to compile with g++-3.4 -> no more problem
> 
> -- System Information:
> Debian Release: testing/unstable
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: i386 (i686)
> Shell:  /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.12
> Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)
> 
> Versions of packages g++-4.0 depends on:
> ii  gcc-4.0                     4.0.0-12     The GNU C compiler
> ii  gcc-4.0-base                4.0.0-12     The GNU Compiler Collection (base 
> ii  libc6                       2.3.2.ds1-22 GNU C Library: Shared libraries an
> ii  libstdc++6-4.0-dev          4.0.0-12     The GNU Standard C++ Library v3 (d
> 
> g++-4.0 recommends no packages.
> 
> -- no debconf information
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: